Electronic Components Datasheet Search
  English  ▼

X  



RFC4568 Distributor

DistributorPart #ManufacturerDescriptionPriceQty.
BuyNow

Avnet Americas
CAS17C102KARFC

KEMET Corporation Ceramic Suppression Capacitor, 1000 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] - Product that comes on tape, but is not reeled (Alt: 71AH0541)
RoHS : Not Compliant
5,000 : $0.833
1,000 : $0.85
500 : $0.887
250 : $0.954
100 : $1.02
25 : $1.33
1 : $1.91
0
DDB2U80N12W3RFC39BPSA1

Infineon Technologies AG - Trays (Alt: DDB2U80N12W3RFC39BPSA1)
RoHS : Compliant
128 : $175.70338
64 : $176.60905
32 : $177.51476
16 : $178.42044
8 : $179.32613
0
CAS17C102KARFC

KEMET Corporation Ceramic Suppression Capacitor, 1000 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] - Tape and Reel (Alt: CAS17C102KARFC)
RoHS : Compliant
1,000 : $0.7205
0
CAS17C221KARFC

KEMET Corporation Ceramic Suppression Capacitor, 220 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] - Tape and Reel (Alt: CAS17C221KARFC)
RoHS : Compliant
2,000 : $0.658
0
CAS18C181KARFC

KEMET Corporation Ceramic Suppression Capacitor, 180 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1812 [4532 Metric] - Tape and Reel (Alt: CAS18C181KARFC)
RoHS : Compliant
1,000 : $1.10333
0
CAS26C182KARFC

KEMET Corporation Ceramic Suppression Capacitor, 1800 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2211 [5728 Metric] - Tape and Reel (Alt: CAS26C182KARFC)
RoHS : Compliant
500 : $0.7835
0
228ADS1ARFCWD

CTS Corporation - Trays (Alt: 228ADS1ARFCWD)
RoHS : Compliant
40,000 : $1.4406
20,000 : $1.44795
10,000 : $1.4553
5,000 : $1.53364
1,000 : $1.55875
0
228ADS2ARFCAE

CTS Corporation - Trays (Alt: 228ADS2ARFCAE)
RoHS : Compliant
40,000 : $1.2642
20,000 : $1.27065
10,000 : $1.2771
5,000 : $1.28355
1,000 : $1.29
0
228ADVARFCBBE

CTS Corporation - Trays (Alt: 228ADVARFCBBE)
RoHS : Compliant
40,000 : $1.2054
20,000 : $1.21155
10,000 : $1.2177
5,000 : $1.22385
1,000 : $1.23
0
228CMVARFCNR

CTS Corporation - Tape and Reel (Alt: 228CMVARFCNR)
RoHS : Compliant
43,200 : $1.3426
21,600 : $1.34945
10,800 : $1.3563
5,400 : $1.43033
1,350 : $1.45375
0
228ADS2ARFCMSB

CTS Corporation - Trays (Alt: 228ADS2ARFCMSB)
RoHS : Compliant
40,000 : $1.2642
20,000 : $1.27065
10,000 : $1.2771
5,000 : $1.28355
1,000 : $1.29
0
228CMVARFCMBAR

CTS Corporation - Tape and Reel (Alt: 228CMVARFCMBAR)
RoHS : Compliant
43,200 : $1.4014
21,600 : $1.40855
10,800 : $1.4157
5,400 : $1.49182
1,350 : $1.51625
0
ACCRFCL25

Vishay Intertechnologies - Bulk (Alt: ACCRFCL25)
RoHS : Not Compliant
80 : $56.01787
40 : $56.30514
20 : $56.59241
10 : $65.637
5 : $66.3
0
IRFC450B

Vishay Intertechnologies - Bulk (Alt: IRFC450B)
RoHS : Not Compliant
0
228ADS2ARFCBBC

CTS Corporation - Trays (Alt: 228ADS2ARFCBBC)
RoHS : Compliant
40,000 : $1.2642
20,000 : $1.27065
10,000 : $1.2771
5,000 : $1.28355
1,000 : $1.29
0

Newark
MFR3-680RFC

TT Electronics Welwyn Components Through Hole Metal Film Resistor, Mfr Se; |Tt Electronics/welwyn MFR3-680RFC
RoHS : Compliant
10 : $0.165
20 : $0.138
30 : $0.11
50 : $0.109
100 : $0.108
250 : $0.106
500 : $0.104
1,000 : $0.102
5,542
TLP785(GR,F(C

Toshiba America Electronic Components Optocoupler, Transistor, 5Kv, Dip-4; |Toshiba TLP785(GR, F(C
RoHS : Compliant
1 : $0.451
10 : $0.365
100 : $0.255
500 : $0.224
1,000 : $0.199
2,500 : $0.166
10,000 : $0.161
2,542
CAS17C102KARFC

KEMET Corporation Cap, Sup, Cer, 1000Pf, ±10%, X1/Y2; |Kemet CAS17C102KARFC
RoHS : Compliant
1 : $1.91
25 : $1.33
100 : $1.02
250 : $0.954
500 : $0.887
1,000 : $0.85
5,000 : $0.833
1,000
CAS17C102KARFC

KEMET Corporation Cap, Sup, Cer, 1000Pf, ±10%, X1/Y2; |Kemet CAS17C102KARFC
RoHS : Compliant
1 : $1.91
25 : $1.33
100 : $1.02
250 : $0.954
500 : $0.887
1,000 : $0.85
5,000 : $0.833
1,000
GRFC-7

Kitagawa Industries Co Ltd Ferrite Core, Split, 7Mm, 45Ohm; |Kgs Kitagawa GRFC-7
RoHS : Compliant
1 : $3.6
10 : $3.25
25 : $3.03
50 : $2.82
100 : $2.55
500 : $2.34
1,000 : $2.07
2,500 : $1.94
362
FCA-S2SR-FCAFCA-01M

L-com Inc Cable Assy, L-Com Fca-S2Sr-Fcafca-01M; |L-Com FCA-S2SR-FCAFCA-01M
RoHS : Not Compliant
1 : $11.8
5 : $11.49
10 : $11.18
25 : $10.87
50 : $10.56
100 : $10.25
250 : $9.69
20
CAS17C102KARFC

KEMET Corporation Suppression Cap, 1000Pf, Class X1/Y2; |Kemet CAS17C102KARFC
RoHS : Compliant
100 : $1.03
250 : $0.962
500 : $0.893
1,000 : $0.856
5,000 : $0.839
13
CAS17C102KARFC

KEMET Corporation Suppression Cap, 1000Pf, Class X1/Y2; |Kemet CAS17C102KARFC
RoHS : Compliant
1 : $1.92
25 : $1.34
100 : $1.03
250 : $0.962
500 : $0.893
1,000 : $0.856
5,000 : $0.839
13
FCA-S2SR-FCASTU-05M

L-com Inc Fc-Apc To St-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASTU-05M
RoHS : Not Compliant
1 : $11.29
10 : $10.53
25 : $9.88
50 : $8.78
100 : $8.43
250 : $8.26
500 : $8.09
5
FCA-S2SR-FCAFCU-05M

L-com Inc Fc-Apc To Fc-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCAFCU-05M
RoHS : Not Compliant
1 : $11.41
10 : $10.65
25 : $9.98
50 : $8.88
100 : $8.52
250 : $8.35
500 : $8.18
4
RFCT-N-CAP-GS-1

Global Connector Technology Mtl Protective Cap/Brass/N-Typ Jack Conn; |Gct RFCT-N-CAP-GS-1
RoHS : Compliant
1 : $5.67
10 : $4.86
25 : $4.57
50 : $4.35
100 : $4.16
250 : $3.91
500 : $3.73
1,000 : $3.57
2
FCA-S2SR-FCASCU-02M

L-com Inc Fc-Apc To Sc-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASCU-02M
RoHS : Not Compliant
1 : $12.44
10 : $11.43
25 : $10.59
50 : $9.8
100 : $9.19
250 : $8.63
500 : $8.12
2
FCA-S2SR-FCAFCA-15M

L-com Inc Fc-Apc To Fc-Apc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCAFCA-15M
RoHS : Not Compliant
1 : $21.24
5 : $19.78
10 : $18.8
25 : $17.92
50 : $16.87
100 : $15.93
1
FCA-S2SR-FCASCU-01M

L-com Inc Fc-Apc To Sc-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASCU-01M
RoHS : Not Compliant
1 : $2.4
10 : $2.26
50 : $2.11
100 : $1.94
250 : $1.85
500 : $1.71
1,000 : $1.68
2,500 : $1.64
1
FCA-S2SR-FCASCA-02M

L-com Inc Fc-Apc To Sc-Apc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASCA-02M
RoHS : Not Compliant
1 : $9.88
10 : $9.22
25 : $8.64
50 : $7.68
100 : $7.37
250 : $7.22
500 : $7.08
1

NXP Semiconductors
1320XRFC

NXP Semiconductors MC1320X RF DAUGHTER CARD,
RoHS : Not Compliant
1 : $90.85
0

RS
1609133-2 (6ESRFC3)

TE Connectivity IEC SOCKET, 15 A/250 VAC, QC TABS TERMINAL, PANEL MOUNT, SR SERIES
1 : $5.12
25 : $4.71
50 : $4.41
100 : $4.18
250 : $3.95
838
RFC-2216

Quest Technology International Inc CABLE ASSEMBLY, UHF PLUG X2, RG-58A/U CBL, 10FT., NON BOOTED
1 : $39.6
44
CRF-CX

ILME UK Ltd ACCESSORY, STAINLESS STEEL FEMALE CODING PIN FOR MIXO
1 : $1.72
50 : $1.55
100 : $1.46
250 : $1.41
500 : $1.36
28
RFC-1326

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG, BNC JACK, RG-59B/U CBL,10FT.,BLACK, UL STDS, NON BOOTED
1 : $6.29
13
RT-120E-R+FC015

PATLITE Corporation REVOLVING LIGHT, 162MM, 32 SOUND HORN, 105DB, 4 CHANNEL, 120VAC, BEIGE, RED
1 : $580.27
3 : $551.25
7
RFC-2215

Quest Technology International Inc CABLE ASSEMBLY, UHF PLUG X2, RG-58A/U CBL, 7FT.
1 : $18.8
5
RT-24E-R+FC015

PATLITE Corporation ROTATING BEACON WITH 8-CHANNEL ALARM WITH 32 PRE-PROGRAMMED SOUNDS; RED
1 : $519.88
3 : $493.89
3
RFC-1813

Quest Technology International Inc CABLE ASSEMBLY, N PLUG X2, RG-58A/U CBL, 36"
1 : $10.7
2
RFC-1533

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-58C/U CBL, 36", NON BOOTED
1 : $6.15
1
RFC-1112

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG X2, RG-58A/U CBL, 24", BLACK, UL STDS, NON BOOTED
1 : $4.95
1
RFC-1114

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG X2, RG-58A/U CBL, 5FT., BLACK, UL STDS, NON BOOTED
1 : $5.58
1
DGRF-C-GF-25-50-P

Festo GUIDED ACTUATOR
1 : $535.72
1
CRFCF-PN210T

Sealmaster MOUNTED BALL BEARING, FLANGE, PILOTED, STD DUTY, TRIPLE LIP CONTACT SEAL, 50MM
1 : $4,176.05
0
CAS17C102KARFC

KEMET Corporation CAPACITOR, FILM, SFTY 1808 1NF X1 250 / Y2 250 X7R, REEL
RoHS : Compliant
1,000 : $0.65
2,000 : $0.63
0
GRFC207D-35MM (PER.GRFC207)

PEER Bearing Company PEER MOUNTED COMPONENTS (MC)
1 : $56.15
10 : $53.34
0

STMicroelectronics
SPSGRFC-868

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $17.49
10 : $15.71
25 : $14.47
100 : $13.38
288 : $12.76
24
SPSGRFC-433

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $11.02
10 : $10.3
25 : $10.23
50 : $10.23
100 : $10.07
250 : $9.9
500 : $9.74
0
SPSGRFC-915

STMicroelectronics Sub-1 GHz (433, 868 or 915 MHz) programmable transceiver module with UFL connector
RoHS : Compliant
1 : $17.52
10 : $16.11
25 : $15.45
100 : $13.61
288 : $12.94
0

Microchip Technology Inc
INTRFCEV

Microchip Technology Inc Power Supply and Interface Noise Board, Projected EOL:
1 : $83.48
3
MRFC544

Microchip Technology Inc 200MHZ, CW, 25V, NPN Power Transistor, DIE, Projected EOL: 2050-10-27 - Contact for Pricing
0
MRFC545

Microchip Technology Inc 200MHZ, CW, 25V, PNP Power Transistor, DIE, Projected EOL: 2050-10-27 - Contact for Pricing
0

Bisco Industries
MS28774-446 - SCARF CUT

MS O-RINGS
39
RFCAERNFTF

MISC. INDUSTRIAL CONNECTORS
2
MIL-S-22473 SURF COND

Military Specifications
1
Z-RFC-P30

MISCELLANEOUS
1

Rochester Electronics
NCP392CRFCCT1G

onsemi Power Supply Support Circuit, PBGA12
RoHS : Compliant
100,000 : $0.3474
10,000 : $0.4146
1,000 : $0.465
500 : $0.5043
100 : $0.5603
219,000
NCP456RFCCT2G

onsemi Power Supply Support Circuit, Fixed, 1 Channel, PBGA6
RoHS : Compliant
100,000 : $0.206
10,000 : $0.2459
1,000 : $0.2758
500 : $0.2991
100 : $0.3323
21,000
NCP392DRFCCT1G

onsemi Power Supply Support Circuit, Adjustable, 1 Channel, PBGA12
RoHS : Compliant
100,000 : $0.344
10,000 : $0.4106
1,000 : $0.4605
500 : $0.4993
100 : $0.5548
93,708
NCP458RFCT2G

onsemi Buffer/Inverter Based Peripheral Driver, 1 Driver, PBGA8
RoHS : Compliant
100,000 : $0.2211
10,000 : $0.2639
1,000 : $0.296
500 : $0.3209
100 : $0.3566
16,835
NCP392ARFCCT1G

onsemi Power Supply Support Circuit, Adjustable, 1 Channel, PBGA12
RoHS : Compliant
100,000 : $0.3474
10,000 : $0.4146
1,000 : $0.465
500 : $0.5043
100 : $0.5603
1,157,125
AUIRFC8407TR

Infineon Technologies AG 30V-250V N-Channel Power MOSFET Bare Die
RoHS : Not Compliant
100,000 : $0.4095
10,000 : $0.4888
1,000 : $0.5482
500 : $0.5944
100 : $0.6605
116,606
DDB2U60N12W3RFC39BPSA1

Infineon Technologies AG DDB2U60N12W3RF_C39 - Low Power Easy
RoHS : Compliant
1,000 : $126.47
500 : $130.79
100 : $135.1
25 : $139.41
1 : $143.72
568
AUIRFC8407TR

International Rectifier 30V-250V N-Channel Power MOSFET Bare Die
RoHS : Not Compliant
100,000 : $0.4095
10,000 : $0.4888
1,000 : $0.5482
500 : $0.5944
100 : $0.6605
306,276
ISL9000IRFCZ

Intersil Corporation Fixed Positive LDO Regulator, 2 Output, 2.5V1, 1.8V2, PDSO10
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
19
ISL9014IRFCZ

Intersil Corporation Fixed Positive LDO Regulator
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
42
ISL9014IRFCZ-T

Intersil Corporation Fixed Positive LDO Regulator, 2 Output, 2.5V1, 1.8V2, CMOS, PDSO10
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
5,950
DF2646RFC20J

Renesas Electronics Corporation Microcontroller 16-Bit, 256KB Flash, H8S/2600
RoHS : Compliant
10,000 : $22.49
1,000 : $23.89
500 : $25.3
100 : $26.7
25 : $28.11
13
M3030RFCPGP#U5

Renesas Electronics Corporation IC MCU 16BIT 128KB FLASH 48LQFP
RoHS : Compliant
10,000 : $7.15
1,000 : $7.6
500 : $8.05
100 : $8.49
25 : $8.94
1,734

Sager
ACM20-4-AC1-R-F-C

Murata Power Solutions Digital Panel Meters AC POWR METER-100A FREQUENCY
1 : $66.24
10 : $62.51
25 : $61.38
50 : $60.79
100 : $59.49
53
A4/0-38RF-C

Panduit Corp Terminals Battery Cable Lug, 2 AWG, 5/16 Stud, 90
1 : $6.49
25 : $6.19
62 : $5.58
124 : $5.16
249 : $4.96
497 : $4.96
0
HBL5262RFC1W

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 15A, 5-15R, WH
1 : $158.72
5 : $152.2
0
HBL5362RFC1GY

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, GY
1 : $166.57
5 : $159.73
0
HBL5362RFC2GN

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 20A, 5-20R, GN
1 : $158.72
5 : $152.2
0
ROCKERVVEORFCS00-000

Carling Technologies Switch Actuators
1 : $2.83
68 : $2.59
170 : $2.39
417 : $1.74
833 : $1.58
1,667 : $1.53
0
HRFC-P3-H(61)

Hirose Electric Co Ltd Fiber Optic Connectors
0
A2/0-12RF-C

Panduit Corp Terminals Battery Cable Lug, 2 AWG, 1/4 Stud, 45
1 : $5.6
29 : $5.34
72 : $4.82
144 : $4.45
288 : $4.28
576 : $4.28
0
HBL5362RFC1I

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, IV
1 : $166.57
5 : $159.73
0
HBL5262RFC1GY

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 15A, 5-15R, GY
1 : $158.72
5 : $152.2
0
HBL5262RFC2GN

Hubbell Incorporated RF CTRL RCPT, FULL CONT, 15A, 5-15R, GN
1 : $160.75
3 : $151.57
5 : $145.33
0
NCMH1-RFC

Panduit Corp Wire Ducting & Raceways REPLACEMENT FRONT COVER
1 : $48.31
8 : $43.61
16 : $40.26
32 : $38.77
64 : $38.77
159 : $38.29
0
166LRF-CS737

ABB Group 15KV ELBOW PROBE W-CS737
1 : $31.08
6 : $28.69
16 : $27.42
32 : $26.64
64 : $25.9
129 : $24.86
0
HBL2182RFC1GN

Hubbell Incorporated RF CTRL HGR, SPLT CIRC, 20A, 5-20R, GN
1 : $194.85
4 : $186.85
0
HBL5362RFC2W

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 20A, 5-20R, WH
1 : $158.72
5 : $152.2
0

Coilcraft Direct
RFC0810B-105KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
773
RFC1010B-474KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.39
150 : $1.14
300 : $0.86
600 : $0.51
1,050 : $0.4
2,550 : $0.34
659
RFC1010B-564KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.39
150 : $1.14
300 : $0.86
600 : $0.51
1,050 : $0.4
2,550 : $0.34
624
RFC0807B-105KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
227
RFC1010B-104KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.39
150 : $1.14
300 : $0.86
600 : $0.51
1,050 : $0.4
2,550 : $0.34
225
RFC1010B-186KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.39
150 : $1.14
300 : $0.86
600 : $0.51
1,050 : $0.4
2,550 : $0.34
148
RFC0807B-153KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
120
RFC0807B-565KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
14
RFC0807B-685KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
9
RFC0807B-823KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
0
RFC0810B-394KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
0
RFC0810B-475KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
0
RFC0810B-685KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.28
150 : $1.04
300 : $0.79
600 : $0.48
1,050 : $0.37
2,550 : $0.32
0
RFC0807B-394KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
0
RFC0807B-475KE

Coilcraft Inc Power inductor, 10% tol, RoHS, halogen-free
RoHS : Compliant
1 : $1.15
150 : $0.93
300 : $0.7
600 : $0.42
1,050 : $0.33
2,550 : $0.29
0

TME
RF-C36D0-UTP-AR

Shenzhen Refond Optoelect LED; UV-B; 120°; 80mA; 800mW; λd: 305÷311nm; 4.5÷7.5VDC; SMD
100 : $4.08
25 : $4.35
5 : $4.62
1 : $4.9
466
TLP785(D4-GR.F(C

Toshiba America Electronic Components Optocoupler; THT; Ch: 1; OUT: transistor; Uinsul: 5kV; Uce: 80V; DIP4
2,500 : $0.232
500 : $0.252
100 : $0.272
25 : $0.292
5 : $0.322
299
SPSGRFC-868

STMicroelectronics U.FL; GFSK,GMSK,OOK; 868MHz; SPI; -118dBm; 11.6dBm; SMD; 500kbps
RoHS : Compliant
144 : $12.71
288
RFCT-N-CAP-GS-2

Global Connector Technology Protection cover; IP67; Application: N socket
RoHS : Compliant
500 : $3.44
200 : $3.55
100 : $3.67
50 : $3.81
25 : $3.94
10 : $4.12
1 : $4.84
231
RFCT-SMA-CAP-GS-1

Global Connector Technology Accessories: protection cover; chain; gold-plated; IP67
RoHS : Compliant
100 : $2.72
50 : $2.82
25 : $2.99
10 : $3.3
1 : $4.11
215
RFCT-TNC-CAP-GS-3

Global Connector Technology Protection cover; IP67; Application: TNC socket
RoHS : Compliant
500 : $2.87
200 : $2.99
100 : $3.1
50 : $3.21
25 : $3.32
10 : $3.5
1 : $4.13
211
TLP785(GR.F(C

Toshiba America Electronic Components Optocoupler; THT; Ch: 1; OUT: transistor; Uinsul: 5kV; Uce: 80V; DIP4
1,000 : $0.249
300 : $0.29
50 : $0.374
10 : $0.437
2 : $0.61
209
RF-C37P0-URF-AR

Shenzhen Refond Optoelect LED; UV-C; 120°; 350mA; 3.8W; λd: 270÷280nm; 4.5÷7.5VDC; SMD
25 : $16.0
5 : $17.6
1 : $19.2
7
RFC570B-AIW-DNS

Raystar Optronics Inc Display: TFT; 5.7"; 320x240; Illumin: LED; Dim: 160x109x9.8mm; RGB
5 : $42.74
3 : $43.2
1 : $44.4
5
RFC57EB-AIW-DNG

Raystar Optronics Inc Display: TFT; 5.7"; 320x240; Illumin: LED; Dim: 160x109x9.985mm; RGB
3 : $76.0
1 : $84.0
5
RFC350M-EIW-DRN

Raystar Optronics Inc Display: TFT; 3.5"; 320x240; Illumin: LED; Dim: 100x66.44x5.76mm
3 : $28.55
1 : $30.0
2
RF-CC1101-868

Radiocontrolli Module: RF; 868MHz; SPI; -112dBm; 1.8÷3.6VDC; 12dBm; SMD; 16x9mm
25 : $13.43
5 : $15.67
1 : $16.46
0
RF-CC1310-AT

Radiocontrolli Module: RF; 868/915MHz; SPI; -124dBm; 1.8÷3.8VDC; 14dBm; SMD; SMA
25 : $10.91
5 : $12.54
1 : $13.43
0
SOLX/RF/CL/W/S

Eaton Corporation Signaller: lighting; flashing light; red; Solista Maxi; 9÷60VDC
5 : $67.98
1 : $73.12
0
RFC350X-AWH-DNN

Raystar Optronics Inc Display: TFT; 3.5"; 320x240; Illumin: LED; Dim: 76.84x63.84x3.27mm
25 : $16.45
10 : $17.46
5 : $18.47
3 : $19.23
1 : $20.62
0

Ameya Holding Limited
RFC02MM2STR

ROHM Semiconductor
RoHS : Compliant
1 : $0.46
10 : $0.352
100 : $0.22
500 : $0.15
1,000 : $0.116
3,000 : $0.104
65

ComSIT USA
ADM809XCSURFCAM

Analog Devices Inc Electronic Component
RoHS : Not Compliant
20,000
MFR3100RFC

TT Electronics Welwyn Components Fixed Resistor, Metal Film, 0.4W, 100ohm, 200V, 1% +/-Tol, 50ppm/Cel, Through Hole Mount
RoHS : Compliant
15,000
3301C44RRFCD1T1U1CHAM

Everlight Electronics Co Ltd DIA 3 PIRANHA LED Single Color LED, Red, Water Clear Colorless, T-1, 3mm
RoHS : Compliant
5,360
MFR3422RFC

TT Electronics Welwyn Components Fixed Resistor, Metal Film, 0.4W, 422ohm, 200V, 1% +/-Tol, 50ppm/Cel, Through Hole Mount
RoHS : Compliant
5,000
SAKC164CW4RFCA

Infineon Technologies AG Electronic Component
RoHS : Compliant
4,687
SAKC164SM4RFCA

Infineon Technologies AG 16-BIT SINGLE-CHIP MICROCONTROL LER Microcontroller, CMOS
RoHS : Compliant
1,900
AUIRFC3805TR

International Rectifier Electronic Component
RoHS : Not Compliant
1,000

GLYN GmbH & Co. KG
CAB-GRE-RFC7_KABEL_Y

Great Ideal Co Ltd IDC 2.54-2*5P TO 51021-0800 & A1255H-06P Wireÿ:U
2

Interstate Connecting Components
PKT06RFC22-22P

Amphenol Aerospace 5015 HIGH POWER STR PLG 4#8 PIN ENP
0
MFM062RFC

Amphenol PCD FIBRE
0
PKT06RFC36-5P

Amphenol Aerospace
0
PKT09RFC32-17R

Amphenol Aerospace
0
PKT06RFC32-15T

Amphenol Aerospace 5015 POWER THRD COUPLING PLUG CRIMP 2#0 6#12 TEMPER GRP SKT
0
PKT06RFC32-17P

Amphenol Aerospace HIGH PWR THRD COUPL STR PLUG ELECT CRIMP 4#4 HIGH CRNT PIN
0
PKB06RFC22-22R

Amphenol Aerospace 5015 HIGH PWR W/ BAYONET COUP STR PLUG 4#8 RADSOK ENP
0
PKT06RFC24-10S

Amphenol Aerospace 5015 STR PLG 7#8 SKT ENP
0
PKT06RFC36-3P

Amphenol Aerospace
0
MFM072RFC009

Amphenol PCD FIBRE
0
PKT06RFC32-15R

Amphenol Aerospace PK SKT TEMPER GRIP CONNECTORS
0
PKT02RFC22-22R

Amphenol Aerospace 5015 HIGH POWER BX MNT RCP 4#8 RADSOK ENP
0
PKT02RFC32-01T

Amphenol Aerospace 91-716677-01CT
0
MFM002RFC011

Amphenol PCD FIBRE
0
PKB06RFC24-22T

Amphenol Aerospace 5015 HIGH PWR W/ BAYONET COUP STR PLUG 4#8 TEMPERGRIP SKT
0

NexGen Digital
RFCS04025600CJTT1

Vishay Huntington
2,587

PEI Genesis
PKB05RFC24-12PX

Amphenol Corporation
1 : $0.0
10 : $0.0
25 : $0.0
50 : $0.0
100 : $0.0
0
PKB05RFC24-12PY

Amphenol Corporation
1 : $0.0
10 : $0.0
25 : $0.0
50 : $0.0
100 : $0.0
0

Richardson RFPD
INTRFCEV

Microchip Technology Inc Power Supply And Interface Noise Board
RoHS : Compliant
19 : $95.3
0
P2RFC-2275-420

RF Industries CBL ASSY; 4.3/10 MALE TO 4.3/10 MALE; TFT-402LF; P
RoHS : Not Compliant
0
P2RFC-2275-540

RF Industries CBL ASSY; 4.3/10 MALE TO 4.3/10 MALE; TFT-402LF; P
RoHS : Not Compliant
19 : $154.45
0

Rutronik
RFCT-SMA-CAP-GS-1

Global Connector Technology RF Coax Conn CAP SMA IP67 W
RoHS : Compliant
50 : $2.84
200

Chip 1 Exchange
D12-100-562R-FCS

Vishay Intertechnologies INSTOCK
340,000
D12-100-715R-FCS

Vishay Intertechnologies INSTOCK
220,000
D12-100-768R-FCS

Vishay Intertechnologies INSTOCK
170,000
D12681RFCS

Vishay Intertechnologies INSTOCK
5,000
D12681RFCS

Vishay Intertechnologies INSTOCK
5,000
D25732RFCS

Vishay Roederstein INSTOCK
5,000
D25820RFCS

Vishay Roederstein INSTOCK
5,000
D25511RFCS-1

INSTOCK
5,000
D12931RFCS

INSTOCK
5,000
D12124RFCS

Vishay Draloric INSTOCK
4,950
D12274RFCS

Vishay Roederstein INSTOCK
4,900
D25604RFC

Vishay Roederstein INSTOCK
3,345
D25215RFCS

Vishay Roederstein INSTOCK
2,715
D25649RFCS

Vishay Roederstein INSTOCK
2,170
RFC16474F

Dubilier INSTOCK
1,500

Avnet Abacus
H839RFCA

TE Connectivity Resistor 39 Ohm 1 250 mW Axial Leaded Metal Film Precision (Alt: 1-1879625-5)
RoHS : Compliant
0
H4P150RFCA

TE Connectivity Res Metal Film 150 Ohm 1 1W 50ppmC Conformal AXL ThruHole Bandoliered (Alt: 2-1879621-9)
RoHS : Compliant
0
H4P910RFCA

TE Connectivity Res Metal Film 910 Ohm 1 1W 50ppmC Conformal AXL ThruHole Bandoliered (Alt: 4-1879621-8)
RoHS : Compliant
0
228ADS1ARFCWD

CTS Corporation (Alt: 228ADS1ARFCWD)
RoHS : Compliant
0
228ADS2ARFCAE

CTS Corporation (Alt: 228ADS2ARFCAE)
RoHS : Compliant
0
CAS17C102KARFC

KEMET Corporation Ceramic Suppression Capacitor 1000 pF 10 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C102KARFC)
RoHS : Compliant
0
CAS17C151MARFC

KEMET Corporation Ceramic Suppression Capacitor 150 pF 20 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C151MARFC)
RoHS : Compliant
0
CAS17C221KARFC

KEMET Corporation Ceramic Suppression Capacitor 220 pF 10 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C221KARFC)
RoHS : Compliant
0
CAS18C181KARFC

KEMET Corporation Ceramic Suppression Capacitor 180 pF 10 X1 Y2 250 VAC 250 VAC 1812 4532 Metric (Alt: CAS18C181KARFC)
RoHS : Compliant
0
CAS21C102JARFC

KEMET Corporation Ceramic Suppression Capacitor 1000 pF 5 X1 Y2 250 VAC 250 VAC 2220 5650 Metric (Alt: CAS21C102JARFC)
RoHS : Compliant
0
CAS21C221JARFC

KEMET Corporation Ceramic Suppression Capacitor 220 pF 5 X1 Y2 250 VAC 250 VAC 2220 5650 Metric (Alt: CAS21C221JARFC)
RoHS : Compliant
0
CAS21C561MARFC

KEMET Corporation Ceramic Suppression Capacitor 560 pF 20 X1 Y2 250 VAC 250 VAC 2220 5650 Metric (Alt: CAS21C561MARFC)
RoHS : Compliant
0
CAS26C122MARFC

KEMET Corporation Ceramic Suppression Capacitor 1200 pF 20 X1 Y2 250 VAC 250 VAC 2211 5728 Metric (Alt: CAS26C122MARFC)
RoHS : Compliant
0
CAS26C182KARFC

KEMET Corporation Ceramic Suppression Capacitor 1800 pF 10 X1 Y2 250 VAC 250 VAC 2211 5728 Metric (Alt: CAS26C182KARFC)
RoHS : Compliant
0
HRFC-AT11K-A05(60)

Hirose Electric Co Ltd (Alt: CL0820-8005-8-60)
RoHS : Compliant
0

Avnet Asia
CAS17C102KARFC

KEMET Corporation Ceramic Suppression Capacitor, 1000 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] (Alt: CAS17C102KARFC)
RoHS : Compliant
0
CAS17C331KARFC

KEMET Corporation Ceramic Suppression Capacitor, 330 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] (Alt: CAS17C331KARFC)
RoHS : Compliant
50,000 : $0.50863
25,000 : $0.52167
10,000 : $0.53539
5,000 : $0.54986
3,000 : $0.5574
2,000 : $0.56514
1,000 : $0.5731
0
CAS21C472KARFC

KEMET Corporation Ceramic Suppression Capacitor, 4700 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2220 [5650 Metric] (Alt: CAS21C472KARFC)
RoHS : Compliant
0
NCP456RFCCT2G

onsemi Load Switch, 2 A Single, For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
QTLP650C4TR/FC15-21SYGC/S530-E2/TR8

Everlight Electronics Co Ltd (Alt: QTLP650C4TR/FC15-21SYGC/S530-E2/TR8)
RoHS : Compliant
0
RFCM3328TR13

Qorvo (Alt: RFCM3328TR13)
RoHS : Compliant
0
CAS17C102MARFC

KEMET Corporation (Alt: CAS17C102MARFC)
RoHS : Compliant
0
CAS26C222KARFC

KEMET Corporation Ceramic Suppression Capacitor, 2200 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2211 [5728 Metric] (Alt: CAS26C222KARFC)
RoHS : Compliant
0
TC75W71FU,RF(CB

Toshiba America Electronic Components TOSTC75W71FU,RF(CB CMOS LINEAR IC (Alt: TC75W71FU,RF(CB)
RoHS : Compliant
0
RFCM3327TR13

Qorvo (Alt: RFCM3327TR13)
RoHS : Compliant
0
R5F10RFCAFP#10

Renesas Electronics Corporation Microcontroller 16-Bit RL78 CISC 32KB Flash 44-Pin LQFP (Alt: R5F10RFCAFP#10)
RoHS : Compliant
0
R5F10RFCAFP#50

Renesas Electronics Corporation MCU 16-Bit RL78 CISC 32KB Flash 1.6V to 5.5V 44-Pin LQFP Tray (Alt: R5F10RFCAFP#50)
RoHS : Compliant
0
CAS18C102KARFC

KEMET Corporation (Alt: CAS18C102KARFC)
RoHS : Compliant
0
TLP785(GR,F(C

Toshiba America Electronic Components (Alt: TLP785(GR,F(C)
RoHS : Compliant
0

Avnet Silica
1320XRFC

NXP Semiconductors Daughter Card RF Zigbee Communication Networking MC9S08 (Alt: 1320XRFC)
RoHS : Compliant
0
SRFC015-100

Antenova M2M Zhengi flexible antenna 100mm cable Ipex Cellular 3G 4G and LTE (Alt: SRFC015-100)
RoHS : Compliant
0
SRFC025-200

Antenova M2M AVIA 3G FLEXIBLE ANTENNA 200mm cable (Alt: SRFC025-200)
RoHS : Compliant
0
SRFC025-100

Antenova M2M AVIA 3G FLEXIBLE ANTENNA 100mm cable (Alt: SRFC025-100)
RoHS : Compliant
0
RFCM3328TR13

Qorvo (Alt: RFCM3328TR13)
RoHS : Compliant
0
RFC02MM2STFTR

ROHM Semiconductor Super Fast Recovery Diode 200V 500mA 2Pin SOD123L TR (Alt: RFC02MM2STFTR)
RoHS : Compliant
0
NCP456RFCCT2G

onsemi Load Switch 2 A Single For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
R5F10RFCGFP#50

Renesas Electronics Corporation (Alt: R5F10RFCGFP#50)
RoHS : Compliant
0
STM32WC-RFCKIT

STMicroelectronics Development Kit For STM32W RF Wireless Control (Alt: STM32WC-RFCKIT)
RoHS : Compliant
0
R5F10RFCAFP#10

Renesas Electronics Corporation (Alt: R5F10RFCAFP#10)
RoHS : Compliant
0
M3030RFCPGP#33

Renesas Electronics Corporation 16BIT MCU M16C30P (Alt: M3030RFCPGP#33)
RoHS : Compliant
0
R5F10RFCAFP#50

Renesas Electronics Corporation (Alt: R5F10RFCAFP#50)
RoHS : Compliant
0

Component Electronics, Inc
D11010RFCS

Vishay Intertechnologies IN STOCK SHIP TODAY
1,000 : $0.08
100 : $0.09
1 : $0.12
3,000
RFC-8716-60

RF CONN IN STOCK SHIP TODAY
1,000 : $17.5
100 : $20.19
1 : $26.92
117
RFC-8715-14

RF CONN IN STOCK SHIP TODAY
1,000 : $10.0
100 : $11.54
1 : $15.38
46
RFC-8714-60

RF CONN IN STOCK SHIP TODAY
1,000 : $12.5
100 : $14.42
1 : $19.23
46
RFC1010B-104KE

Coilcraft Inc IN STOCK SHIP TODAY
RoHS : Compliant
1,000 : $1.0
100 : $1.15
1 : $1.54
10
SR-FC-HUB

IN STOCK SHIP TODAY
5
194R-FCA2

AB Connectors Ltd IN STOCK SHIP TODAY
1,000 : $25.0
100 : $28.85
1 : $38.46
3

EBV Elektronik
TLP785F(GR,F(C

Toshiba America Electronic Components Optocoupler 1CH Open Collector 5000Vrms 4Pin DIP Tube (Alt: TLP785F(GR,F(C)
RoHS : Compliant
10,600
TLP785(GR,F(C

Toshiba America Electronic Components Optocoupler DCIN 1CH Transistor DCOUT 4Pin DIP (Alt: TLP785(GR,F(C)
RoHS : Compliant
3,400
TLP785(D4-GR,F(C

Toshiba America Electronic Components Optocoupler DCIN 1CH DCOUT 4Pin PDIP SMD (Alt: TLP785(D4-GR,F(C)
RoHS : Compliant
1,600
NCP456RFCCT2G

onsemi Load Switch 2 A Single For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
M3030RFCPGP#35

Renesas Electronics Corporation 16BIT MCU M16C30P (Alt: M3030RFCPGP#35)
RoHS : Compliant
0
CL8068404069418S RFCP

Intel Corporation Intel Core i79750H Processor 12M Cache up to 450 GHz FCBGA14F Tray (Alt: 999CXN)
RoHS : Compliant
0
CL8068404069606S RFCR

Intel Corporation Intel Core i59300H Processor 8M Cache up to 410 GHz FCBGA14F Tray (Alt: 999CXR)
RoHS : Compliant
0

FDH Electronics
PKB06RFC24-10T

Amphenol Aerospace Circular Conn
13
PKT07RFC20-22P

Amphenol Aerospace Circular Conn
5
PKB06RFC24-12T

Amphenol Aerospace Circular Conn
5
RFC1035-116 ISS A

W L Gore & Associates Cable Assembly
1 : $4,302.222
5 : $4,302.222
10 : $3,951.02
25 : $3,396.491
50 : $3,396.491
100 : $3,281.356
250 : $3,173.77
500 : $3,173.77
1,000 : $3,173.77
2,500 : $3,173.77
10,000 : $3,173.77
3
PERF CARD STK

FDH Electronics Wire Placehldr
2

Flip Electronics
R5F10RFCAFP#30

Renesas Electronics Corporation Stock
RoHS : Compliant
1,221

Master Electronics
H4P150RFCA

TE Connectivity H4P 150R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H4P910RFCA

TE Connectivity H4P 910R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H839RFCA

TE Connectivity H8 39R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H4P240RFCA

TE Connectivity H4P 240R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H868RFCA

TE Connectivity H8 68R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H4P56RFCA

TE Connectivity H4P 56R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H4P13RFCA

TE Connectivity H4P 13R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H4P620RFCA

TE Connectivity H4P 620R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H8150RFCA

TE Connectivity H8 150R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H862RFCA

TE Connectivity H8 62R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H8866RFCA

TE Connectivity H8 866R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H8910RFCA

TE Connectivity H8 910R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H4P390RFCA

TE Connectivity H4P 390R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H4P51RFCA

TE Connectivity H4P 51R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H8330RFCA

TE Connectivity H8 330R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0

Venkel Ltd.
RFCA0402A1T

VENKEL LTD RF Ceramic Antenna;0402;2.45GHz
RoHS : Not Compliant
0
RFCA1206A1T

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA1206A5T

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA1206K1T

VENKEL LTD RF Ceramic Antenna;1206;5GHz
RoHS : Not Compliant
0
RFCA1206Y1T

VENKEL LTD RF Ceramic Antenna;1206;7.37GHz
RoHS : Not Compliant
0
RFCA0805A3T

VENKEL LTD RF Ceramic Antenna;0805;2.4GHz
RoHS : Not Compliant
0
RFCA1206AAT

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA3224YAT

VENKEL LTD RF Ceramic Antenna;3224;6.5GHz
RoHS : Not Compliant
0
RFCA0805A0T

VENKEL LTD RF Ceramic Antenna;0805;2.45GHz
RoHS : Not Compliant
0
RFCA1206E0T

VENKEL LTD RF Ceramic Antenna;1206;1.575GHz
RoHS : Not Compliant
0
RFCA3708A0T

VENKEL LTD RF Ceramic Antenna;3708;2.4GHz
RoHS : Not Compliant
0

Vyrian
RFC0807BV-474KE

Coilcraft Inc General Purpose Inductor, 470uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
16,430
RFC0807BV-105KE

Coilcraft Inc General Purpose Inductor, 1000uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
15,002
NCP392BRFCCT1G

onsemi Power Supply Support Circuit, Fixed, 1 Channel, PBGA12
RoHS : Compliant
13,189
IRFC7314B

Infineon Technologies AG
12,015
NCP458RFCCT2G

onsemi Buffer/Inverter Based Peripheral Driver, 1 Driver, PBGA8
RoHS : Compliant
11,589
RFC0807BV-154KE

Coilcraft Inc General Purpose Inductor, 150uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
9,964
NCP392ARFCCT1G

onsemi Power Supply Support Circuit, Adjustable, 1 Channel, PBGA12
RoHS : Compliant
9,755
SPSGRFC-868

STMicroelectronics
RoHS : Compliant
8,992
STM32W-RFCKIT

STMicroelectronics
8,419
SPSGRFC-433

STMicroelectronics
RoHS : Compliant
5,784
VT451RFCR-ADJ

Analog Devices Inc
5,261
STM32WC-RFCKIT

STMicroelectronics
5,121
NCP392DRFCCT1G

onsemi Power Supply Support Circuit, Adjustable, 1 Channel, PBGA12
RoHS : Compliant
4,091
MFC-20KRFC

Honda Tsushin Kogyo Board Connector, 20 Contact(s), 2 Row(s), Female, 0.1 inch Pitch, Black Insulator, Plug
780
SPSGRFC-915

STMicroelectronics Telecom Circuit
RoHS : Compliant
402

Win Source Electronics
RFCMF1220100M3T

Walsin Technology Corporation CMC 300MA 2LN 80 OHM SMD
RoHS : Compliant
3,245 : $0.0925
2,600 : $0.0963
2,000 : $0.1
1,395 : $0.1076
900 : $0.1113
425 : $0.1188
60,590
HI3516ARFCV200

HiSilicon Technologies Co Ltd
5 : $93.4268
4 : $104.2067
3 : $107.8001
2 : $111.3934
1 : $114.9867
355
HI3521RFCV100

HiSilicon Technologies Co Ltd
10 : $33.116
7 : $36.937
6 : $38.2107
4 : $39.4844
3 : $40.7581
2 : $49.6739
268

Link URL



Does ALLDATASHEET help your business so far?  [ DONATE ]  

About Alldatasheet   |   Advertisement   |   Contact us   |   Privacy Policy   |   Link to Datasheet    |   Link Exchange   |   Manufacturer List
All Rights Reserved짤Alldatasheet.com


Mirror Sites
English : Alldatasheet.com  |   English : Alldatasheet.net  |   Chinese : Alldatasheetcn.com  |   German : Alldatasheetde.com  |   Japanese : Alldatasheet.jp
Russian : Alldatasheetru.com  |   Korean : Alldatasheet.co.kr  |   Spanish : Alldatasheet.es  |   French : Alldatasheet.fr  |   Italian : Alldatasheetit.com
Portuguese : Alldatasheetpt.com  |   Polish : Alldatasheet.pl  |   Vietnamese : Alldatasheet.vn
Indian : Alldatasheet.in  |   Mexican : Alldatasheet.com.mx  |   British : Alldatasheet.co.uk  |   New Zealand : Alldatasheet.co.nz
Family Site : ic2ic.com  |   icmetro.com