Electronic Components Datasheet Search
  English  ▼

X  



RFC092_14 Distributor

DistributorPart #ManufacturerDescriptionPriceQty.
BuyNow

TME
CAS26C152KARFC

YAGEO Corporation Capacitor: ceramic; 1.5nF; 250VAC; X7R; ±10%; SMD; 2211; Thk: 2.794mm
500 : $0.83
500
RF-C36D0-UTP-AR

Shenzhen Refond Optoelect LED; UV-B; 120°; 80mA; 800mW; λd: 305÷311nm; 4.5÷7.5VDC; SMD
100 : $4.08
25 : $4.35
5 : $4.62
1 : $4.9
461
RF-C36N0-URT-AR

Shenzhen Refond Optoelect LED; UV-C; 120°; 80mA; 800mW; λd: 270÷280nm; 4.5÷7.5VDC; SMD
25 : $2.28
5 : $2.58
1 : $2.74
343
TLP785(D4-GR.F(C

Toshiba America Electronic Components Optocoupler; THT; Ch: 1; OUT: transistor; Uinsul: 5kV; Uce: 80V; DIP4
2,500 : $0.233
500 : $0.253
100 : $0.273
25 : $0.294
5 : $0.324
299
RF-C37D0-UTP-AR

Shenzhen Refond Optoelect LED; UV-B; 120°; 80mA; 800mW; λd: 305÷311nm; 4.5÷7.5VDC; SMD
100 : $4.08
25 : $4.35
5 : $4.62
1 : $4.9
288
RFCT-N-CAP-GS-1

Global Connector Technology Protection cover; IP67; chain; Application: N socket
RoHS : Compliant
500 : $3.52
250 : $3.65
100 : $3.89
50 : $4.07
25 : $4.25
10 : $4.49
1 : $5.27
170
RF-C37N0-URT-AR

Shenzhen Refond Optoelect LED; UV-C; 120°; 80mA; 800mW; λd: 270÷280nm; 4.5÷7.5VDC; SMD
25 : $2.28
5 : $2.74
1 : $3.04
120
RF-C37P0-URF-AR

Shenzhen Refond Optoelect LED; UV-C; 120°; 350mA; 3.8W; λd: 270÷280nm; 4.5÷7.5VDC; SMD
25 : $16.0
5 : $17.6
1 : $19.2
7
RFC57EB-AIW-DNG

Raystar Optronics Inc Display: TFT; 5.7"; 320x240; Illumin: LED; Dim: 160x109x9.985mm; RGB
3 : $76.0
1 : $84.0
5
RFC570E-AIW-DNS

Raystar Optronics Inc Display: TFT; 5.7"; 320x240; Illumin: LED; Dim: 141.12x101.55x8mm
5 : $42.48
3 : $42.6
1 : $44.4
5
RFC350X-AWH-DNN

Raystar Optronics Inc Display: TFT; 3.5"; 320x240; Illumin: LED; Dim: 76.84x63.84x3.27mm
25 : $16.45
10 : $17.46
5 : $18.47
3 : $19.23
1 : $20.62
0
SOLX/RF/CL/W/S

Eaton Corporation Signaller: lighting; flashing light; red; Solista Maxi; 9÷60VDC
5 : $68.25
1 : $73.42
0
RFC02MM2STFTR

ROHM Semiconductor Diode: rectifying; SMD; 200V; 0.2A; 35ns; SOD123F; Ufmax: 0.95V
RoHS : Compliant
6,000 : $0.139
3,000 : $0.143
1,000 : $0.148
500 : $0.153
100 : $0.169
10 : $0.206
1 : $0.26
0
CAS17C102KARFC

KEMET Corporation Capacitor: ceramic; X1/Y2; 1nF; 250VAC; X7R; ±10%; SMD; 1808
RoHS : Compliant
5,000 : $0.579
3,000 : $0.583
2,000 : $0.598
1,000 : $0.62
1 : $1.55
0
CAS21C472KARFC

KEMET Corporation Capacitor: ceramic; X1/Y2; 4.7nF; 250VAC; X7R; ±10%; SMD; 2220
RoHS : Compliant
2,500 : $1.19
1,000 : $1.25
500 : $1.3
250 : $1.38
100 : $1.52
50 : $1.65
10 : $2.08
5 : $2.31
1 : $2.84
0

Avnet Americas
260F-U22-CS-11/2-300RF-CS

Omega Engineering FLANGED THERMOWELLS FOR 1/4 AND 3/8 INCH DIAMETER ELEMENTS - Bulk (Alt: 260F-U22-CS-11/2-300RF-CS)
RoHS : Compliant
1 : $522.21
0
CRFC-156/60-A

Omega Engineering HIGH TEMPERATURE, LOW MASS, VACUUM FORMED CERAMIC RADIANT FULL CYLINDER HEATERS - Bulk (Alt: CRFC-156/60-A)
RoHS : Not Compliant
1 : $440.71
0
CRFC-46/240-C-A

Omega Engineering HIGH TEMPERATURE, LOW MASS, VACUUM FORMED CERAMIC RADIANT FULL CYLINDER HEATERS - Bulk (Alt: CRFC-46/240-C-A)
RoHS : Not Compliant
1 : $631.43
0
RFCA8830TR13

Qorvo - Tape and Reel (Alt: RFCA8830TR13)
RoHS : Not Compliant
40,000 : $3.875
20,000 : $3.97436
10,000 : $4.07895
5,000 : $4.18919
2,500 : $4.42857
0
RFCM4363TR7

Qorvo - Tape and Reel (Alt: RFCM4363TR7)
RoHS : Not Compliant
8,000 : $72.27004
4,000 : $72.64257
2,000 : $73.0151
1,000 : $73.38762
500 : $73.76015
0
CAS17C681KARFC

KEMET Corporation Ceramic Suppression Capacitor, 680 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] - Tape and Reel (Alt: CAS17C681KARFC)
RoHS : Compliant
1,000 : $0.7205
0
CAS26C102MARFC

KEMET Corporation Ceramic Suppression Capacitor, 1000 pF, ? 20%, X1 / Y2, 250 VAC, 250 VAC, 2211 [5728 Metric] - Tape and Reel (Alt: CAS26C102MARFC)
RoHS : Compliant
500 : $1.112
0
H836RFCA

TE Connectivity - Boxed Product (Development Kits) (Alt: 1-1879625-4)
RoHS : Compliant
50,000 : $0.33677
25,000 : $0.34424
10,000 : $0.38049
5,000 : $0.41051
500 : $0.43568
0
M3030RFCPGP#33

Renesas Electronics Corporation 16BIT MCU M16C/30P - Trays (Alt: M3030RFCPGP#33)
RoHS : Compliant
1,440 : $8.99115
720 : $9.03798
360 : $9.08481
180 : $9.13164
90 : $9.17846
0
CRFC-36/115-A

Omega Engineering HIGH TEMPERATURE, LOW MASS, VACUUM FORMED CERAMIC RADIANT FULL CYLINDER HEATERS - Bulk (Alt: CRFC-36/115-A)
RoHS : Not Compliant
1 : $508.4
0
CRFC-66/240-C-A

Omega Engineering HIGH TEMPERATURE, LOW MASS, VACUUM FORMED CERAMIC RADIANT FULL CYLINDER HEATERS - Bulk (Alt: CRFC-66/240-C-A)
RoHS : Not Compliant
1 : $912.81
0
RFCA8830SR

Qorvo High Linearity, Low Noise 19dB Gain Block 45MHz to 1218MHz 24dBm 8-Pin SOIC Reel - Tape and Reel (Alt: RFCA8830SR)
RoHS : Not Compliant
1,600 : $6.425
800 : $6.58974
400 : $6.76316
200 : $6.94595
100 : $7.34286
0
H8470RFCA

TE Connectivity - Boxed Product (Development Kits) (Alt: 4-1879625-1)
RoHS : Compliant
50,000 : $0.33677
25,000 : $0.34424
10,000 : $0.38049
5,000 : $0.41051
500 : $0.43568
0
CAS18C271KARFC

KEMET Corporation Ceramic Suppression Capacitor, 270 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1812 [4532 Metric] - Tape and Reel (Alt: CAS18C271KARFC)
RoHS : Compliant
1,000 : $1.13733
0
CAS26C151KARFC

KEMET Corporation Ceramic Suppression Capacitor, 150 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2211 [5728 Metric] - Tape and Reel (Alt: CAS26C151KARFC)
RoHS : Compliant
1,000 : $1.018
0

Newark
MFR3-33RFC

TT Electronics Welwyn Components Res, 33R, 1%, 400Mw, Axial, Metal Film; |Tt Electronics/welwyn MFR3-33RFC
RoHS : Compliant
10 : $0.186
20 : $0.081
30 : $0.065
50 : $0.049
100 : $0.038
250 : $0.028
500 : $0.022
1,000 : $0.019
28,620
MFR3-39RFC

TT Electronics Welwyn Components Res, 39R, 1%, 400Mw, Axial, Metal Film; |Tt Electronics/welwyn MFR3-39RFC
RoHS : Compliant
10 : $0.186
20 : $0.081
30 : $0.065
50 : $0.049
100 : $0.038
250 : $0.028
500 : $0.022
1,000 : $0.019
10,735
CAS17C681KARFC

KEMET Corporation Suppression Cap, 680Pf, Class X1/Y2; |Kemet CAS17C681KARFC
RoHS : Compliant
1 : $2.13
25 : $1.48
100 : $1.14
250 : $1.06
500 : $0.982
1,000 : $0.926
5,000 : $0.839
677
CAS17C681KARFC

KEMET Corporation Suppression Cap, 680Pf, Class X1/Y2; |Kemet CAS17C681KARFC
RoHS : Compliant
100 : $1.14
250 : $1.06
500 : $0.982
1,000 : $0.926
5,000 : $0.839
677
RFCT-SMA-CAP-GS-7

Global Connector Technology Protective Cap With Gasket, Sma Jack; |Gct RFCT-SMA-CAP-GS-7
RoHS : Compliant
1 : $4.33
10 : $3.98
25 : $3.79
50 : $3.68
100 : $3.56
250 : $3.15
500 : $2.83
1,000 : $2.7
460
RFC1010B-104KE

Coilcraft Inc Inductor, 100Uh, 2.65A, 10%, Power; |Coilcraft RFC1010B-104KE
RoHS : Compliant
1 : $1.63
10 : $1.4
25 : $1.31
50 : $1.18
100 : $1.04
500 : $0.989
1,000 : $0.939
2,500 : $0.89
149
RFC1010B-394KE

Coilcraft Inc Inductor, 390Uh, 1.4A, 10%, Power; |Coilcraft RFC1010B-394KE
RoHS : Compliant
1 : $1.63
10 : $1.4
25 : $1.31
50 : $1.18
100 : $1.04
500 : $0.989
1,000 : $0.939
2,500 : $0.89
137
RFC1010B-475KE

Coilcraft Inc Inductor, 4.7Mh, 0.41A, 10%, Power; |Coilcraft RFC1010B-475KE
RoHS : Compliant
1 : $1.63
10 : $1.4
25 : $1.31
50 : $1.18
100 : $1.04
500 : $0.989
1,000 : $0.939
2,500 : $0.89
133
RFC0807B-475KE

Coilcraft Inc Inductor, 4.7Mh, 0.29A, 10%, Power; |Coilcraft RFC0807B-475KE
RoHS : Compliant
1 : $1.16
10 : $0.994
25 : $0.911
50 : $0.822
100 : $0.733
500 : $0.683
1,000 : $0.651
2,500 : $0.602
103
RFC1010B-186KE

Coilcraft Inc Inductor, 18Mh, 0.21A, 10%, Power; |Coilcraft RFC1010B-186KE
RoHS : Compliant
1 : $1.63
10 : $1.4
25 : $1.31
50 : $1.18
100 : $1.04
500 : $0.989
1,000 : $0.939
2,500 : $0.89
77
RFC0810B-125KE

Coilcraft Inc Inductor, 1.2Mh, 0.58A, 10%, Power; |Coilcraft RFC0810B-125KE
RoHS : Compliant
1 : $1.64
10 : $1.41
25 : $1.3
50 : $1.18
100 : $1.05
500 : $0.976
1,000 : $0.929
2,500 : $0.859
21
FCA-S1SR-FCSC-01M

L-com Inc Fc/Sc 9/125 Singlemode Simplex Fiber Pat; |L-Com FCA-S1SR-FCSC-01M
RoHS : Not Compliant
1 : $9.29
10 : $8.67
25 : $8.13
50 : $7.22
100 : $6.93
250 : $6.79
500 : $6.65
9
FCA-S2SR-FCASCU-03M

L-com Inc Fc-Apc To Sc-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASCU-03M
RoHS : Not Compliant
1 : $11.05
10 : $10.32
25 : $9.67
50 : $8.6
100 : $8.25
250 : $8.09
500 : $7.92
8
FCA-S2SR-FCASTU-05M

L-com Inc Fc-Apc To St-Upc 9/125 Singlemode Simple; |L-Com FCA-S2SR-FCASTU-05M
RoHS : Not Compliant
1 : $11.29
10 : $10.53
25 : $9.88
50 : $8.78
100 : $8.43
250 : $8.26
500 : $8.09
5
RFC1010B-474KE

Coilcraft Inc Inductor, 470Uh, 1.25A, 10%, Power; |Coilcraft RFC1010B-474KE
RoHS : Compliant
1 : $1.63
10 : $1.4
25 : $1.31
50 : $1.18
100 : $1.04
500 : $0.989
1,000 : $0.939
2,500 : $0.89
3

RS
RFC-2216

Quest Technology International Inc CABLE ASSEMBLY, UHF PLUG X2, RG-58A/U CBL, 10FT., NON BOOTED
1 : $39.6
44
CRF-CX

ILME UK Ltd ACCESSORY, STAINLESS STEEL FEMALE CODING PIN FOR MIXO
1 : $1.8
50 : $1.62
100 : $1.53
250 : $1.48
500 : $1.43
28
RFC-1326

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG, BNC JACK, RG-59B/U CBL,10FT.,BLACK, UL STDS, NON BOOTED
1 : $6.29
13
RT-120E-R+FC015

PATLITE Corporation REVOLVING LIGHT, 162MM, 32 SOUND HORN, 105DB, 4 CHANNEL, 120VAC, BEIGE, RED
1 : $580.27
3 : $551.25
7
RFC-2215

Quest Technology International Inc CABLE ASSEMBLY, UHF PLUG X2, RG-58A/U CBL, 7FT.
1 : $18.8
5
RT-24E-R+FC015

PATLITE Corporation ROTATING BEACON WITH 8-CHANNEL ALARM WITH 32 PRE-PROGRAMMED SOUNDS; RED
1 : $571.87
3 : $543.27
3
RFC-1813

Quest Technology International Inc CABLE ASSEMBLY, N PLUG X2, RG-58A/U CBL, 36"
1 : $10.7
2
RFC-1112

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG X2, RG-58A/U CBL, 24", BLACK, UL STDS, NON BOOTED
1 : $4.95
1
RFC-1533

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-58C/U CBL, 36", NON BOOTED
1 : $6.15
1
RFC-1114

Quest Technology International Inc CABLE ASSEMBLY, BNC PLUG X2, RG-58A/U CBL, 5FT., BLACK, UL STDS, NON BOOTED
1 : $5.58
1
DGRF-C-GF-25-50-P

Festo GUIDED ACTUATOR
1 : $535.72
1
CRFCF-PN212

Sealmaster MOUNTED BALL BEARING, FLANGE, PILOTED, STD DUTY, TRIPLE LIP CONTACT SEAL, 60MM
5 : $983.78
0
CRFC-PN23T RMW

Sealmaster MOUNTED BALL BEARING, FLANGE, FOUR BOLT, STD, TRIPLE LIP CONTACT SEAL, 1.438IN
1 : $948.38
0
LC42USRC1000GDFRFC

L-com Inc 42U Serv. Rack Cab.1000mm(D),Glass, perf. rear, FC
1 : $1,740.0
0
GRFC207D-35MM (PER.GRFC207)

PEER Bearing Company PEER MOUNTED COMPONENTS (MC)
1 : $56.15
10 : $53.34
0

Microchip Technology Inc
INTRFCEV

Microchip Technology Inc Power Supply and Interface Noise Board, Projected EOL:
1 : $83.48
3
MRFC545

Microchip Technology Inc 200MHZ, CW, 25V, PNP Power Transistor, DIE, Projected EOL: 2050-10-27 - Contact for Pricing
0
MRFC544

Microchip Technology Inc 200MHZ, CW, 25V, NPN Power Transistor, DIE, Projected EOL: 2050-10-27 - Contact for Pricing
0

Bisco Industries
MS28774-446 - SCARF CUT

MS O-RINGS
39
RFCAERNFTF

MISC. INDUSTRIAL CONNECTORS
2
MIL-S-22473 SURF COND

Military Specifications
1
Z-RFC-P30

MISCELLANEOUS
1

Rochester Electronics
NCP392ARFCCT1G

onsemi Power Distribution Switch General Purpose N-Channel 1 12-BGA T/R
RoHS : Compliant
100,000 : $0.3474
10,000 : $0.4146
1,000 : $0.465
500 : $0.5043
100 : $0.5603
1,157,125
NCP392CRFCCT1G

onsemi Specialized Power Management Overvoltage Protection Controller 12-BGA T/R
RoHS : Compliant
100,000 : $0.3474
10,000 : $0.4146
1,000 : $0.465
500 : $0.5043
100 : $0.5603
219,000
NCP392DRFCCT1G

onsemi Specialized Power Management Overvoltage Protection Controller 12-BGA T/R
RoHS : Compliant
100,000 : $0.344
10,000 : $0.4106
1,000 : $0.4605
500 : $0.4993
100 : $0.5548
93,708
NCP456RFCCT2G

onsemi Power Distribution Switch General Purpose N-Channel 1 OUT High Side 6-BGA T/R
RoHS : Compliant
100,000 : $0.206
10,000 : $0.2459
1,000 : $0.2758
500 : $0.2991
100 : $0.3323
21,000
NCP458RFCT2G

onsemi Power Distribution Switch General Purpose N-Channel 1 OUT High Side 8-BGA T/R
RoHS : Compliant
100,000 : $0.2211
10,000 : $0.2639
1,000 : $0.296
500 : $0.3209
100 : $0.3566
16,835
AUIRFC8407TR

Infineon Technologies AG MOSFET N-Channel 306A Die
RoHS : Not Compliant
100,000 : $0.4095
10,000 : $0.4888
1,000 : $0.5482
500 : $0.5944
100 : $0.6605
116,606
DDB2U60N12W3RFC39BPSA1

Infineon Technologies AG IGBT MOD 950V 135A 20mW Tray
RoHS : Compliant
1,000 : $126.47
500 : $130.79
100 : $135.1
25 : $139.41
1 : $143.72
568
AUIRFC8407TR

International Rectifier MOSFET N-Channel 306A Die
RoHS : Not Compliant
100,000 : $0.4095
10,000 : $0.4888
1,000 : $0.5482
500 : $0.5944
100 : $0.6605
306,276
ISL9000IRFCZ

Intersil Corporation Fixed Positive LDO Regulator, 2 Output, 2.5V1, 1.8V2, PDSO10
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
19
ISL9014IRFCZ

Intersil Corporation Fixed Positive LDO Regulator
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
42
ISL9014IRFCZ-T

Intersil Corporation Fixed Positive LDO Regulator, 2 Output, 2.5V1, 1.8V2, CMOS, PDSO10
RoHS : Compliant
100,000 : $0.9419
10,000 : $1.12
1,000 : $1.26
500 : $1.37
100 : $1.52
5,950
DF2646RFC20J

Renesas Electronics Corporation Microcontroller 16-Bit, 256KB Flash, H8S/2600
RoHS : Compliant
10,000 : $22.49
1,000 : $23.89
500 : $25.3
100 : $26.7
25 : $28.11
13
M3030RFCPGP#U5

Renesas Electronics Corporation IC MCU 16BIT 128KB FLASH 48LQFP
RoHS : Compliant
10,000 : $7.15
1,000 : $7.6
500 : $8.05
100 : $8.49
25 : $8.94
1,734

Sager
FDSRFC.AFSX340.POM.BRW.NOTXT

OMRON Electronic Components FD SRFC,AF SX340,POM,BRW,NOTXT
0
HBL5362RFC1W

Hubbell Incorporated RF CTRL RCPT, SPLT CIRC, 20A, 5-20R, WH
1 : $166.57
5 : $159.73
0
HBL5262RFC2BK

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 15A, 5-15R, BK
1 : $160.75
3 : $151.57
5 : $145.33
0
HBL5262RFC2LA

Hubbell Incorporated RF CTRL RCPT, FULL CTRLD, 15A, 5-15R, LA
1 : $160.75
3 : $151.57
5 : $145.33
0
RFC500-12

ABB Group CU CRAB CONN ROLLBK INS COMP 500 12
5 : $4,386.56
0
CRFC5EI-X

Panduit Corp Wire Ducting & Raceways CROSS FITTING W/1 RADIUS
0
A4/0-56RF-C

Panduit Corp Terminals Battery Cable Lug, 1/0 AWG, 1/2 Stud
1 : $5.74
28 : $5.47
70 : $4.94
141 : $4.56
281 : $4.39
562 : $4.39
0
RFC500-16

ABB Group CU CRAB CONN ROLLBK INS COMP 500 16
5 : $4,528.3
0
HBL2172RFC2I

Hubbell Incorporated RF CTRL HGR, FULL CTRLD, 15A, 5-15R, IV
1 : $182.28
4 : $174.79
0
HBL2182RFC1I

Hubbell Incorporated RF CTRL HGR, SPLT CIRC, 20A, 5-20R, IV
1 : $194.85
4 : $186.85
0
HSCP-HRFCJ-1AS(60)

Hirose Electric Co Ltd Fiber Optic Connectors ADAPTER RCPT SC-FC
0
PSR-FC100

IDEC Corporation DIN Rail Power Supplies
0
HRFC-P16-W(60)

Hirose Electric Co Ltd Fiber Optic Connectors FIBER OPTIC CONN
0
ROCKERVVEORFCS00-000

Carling Technologies Switch Actuators
1 : $2.83
68 : $2.59
170 : $2.39
417 : $1.74
833 : $1.58
1,667 : $1.53
0
274LRF-CS2034

ABB Group 25KV 200A ELBOW PROBE WC-CS2034
1 : $39.28
5 : $36.26
13 : $34.66
25 : $33.67
51 : $32.74
102 : $31.43
0

Ameya Holding Limited
RFC02MM2STR

ROHM Semiconductor 超快速恢复二极管
RoHS : Compliant
1 : $0.46
10 : $0.352
100 : $0.22
500 : $0.15
1,000 : $0.116
3,000 : $0.104
65

ComSIT USA
ADM809XCSURFCAM

Analog Devices Inc Electronic Component
RoHS : Not Compliant
20,000
MFR3100RFC

TT Electronics Welwyn Components Fixed Resistor, Metal Film, 0.4W, 100ohm, 200V, 1% +/-Tol, 50ppm/Cel, Through Hole Mount
RoHS : Compliant
15,000
3301C44RRFCD1T1U1CHAM

Everlight Electronics Co Ltd DIA 3 PIRANHA LED Single Color LED, Red, Water Clear Colorless, T-1, 3mm
RoHS : Compliant
5,360
MFR3422RFC

TT Electronics Welwyn Components Fixed Resistor, Metal Film, 0.4W, 422ohm, 200V, 1% +/-Tol, 50ppm/Cel, Through Hole Mount
RoHS : Compliant
5,000
SAKC164CW4RFCA

Infineon Technologies AG Electronic Component
RoHS : Compliant
4,687
SAKC164SM4RFCA

Infineon Technologies AG 16-BIT SINGLE-CHIP MICROCONTROL LER Microcontroller, CMOS
RoHS : Compliant
1,900
AUIRFC3805TR

International Rectifier Electronic Component
RoHS : Not Compliant
1,000

GLYN GmbH & Co. KG
CAB-GRE-RFC7_KABEL_Y

Great Ideal Co Ltd IDC 2.54-2*5P TO 51021-0800 & A1255H-06P Wireÿ:U
2

Interstate Connecting Components
RFCT-SMA-CAP-GS-3

Global Connector Technology SMA CAP W/CHAIN IP67
RoHS : Compliant
1 : $4.3922
50 : $3.7966
120 : $3.6129
230 : $3.5
250 : $3.5
62
PKT09RFC28-22R

Amphenol Aerospace
0
PKT02RFC22-22R

Amphenol Aerospace 5015 HIGH POWER BX MNT RCP 4#8 RADSOK ENP
0
PKT02RFC32-01T

Amphenol Aerospace 91-716677-01CT
0
MFM002RFC009

Amphenol PCD FIBRE
0
MFM062RFC

Amphenol PCD FIBRE
0
PKT06RFC22-22P

Amphenol Aerospace 5015 HIGH POWER STR PLG 4#8 PIN ENP
0
PKT06RFC32-17S

Amphenol Aerospace 5015 STR PLG 4#4 SKT
0
MFM062RFC009

Amphenol PCD FIBRE
0
PKT06RFC32-15R

Amphenol Aerospace PK SKT TEMPER GRIP CONNECTORS
0
PKT06RFC24-10P

Amphenol Aerospace HIGH POWER 5015 STR PLUG 7#8 PIN ENP
0
PKB06RFC32-1R

Amphenol Aerospace
0
PKB06RFC32-17R

Amphenol Aerospace 5015 HIGH PWR W/ BAYONET COUP STR PLUG 4#4 RADSOK ENP
0
PKT06RFC32-6T

Amphenol Aerospace POWER 5015 STR PLG 2#4 3#8 2#12 16#16 SKT ENP
0
PKB06RFC22-22R

Amphenol Aerospace 5015 HIGH PWR W/ BAYONET COUP STR PLUG 4#8 RADSOK ENP
0

NexGen Digital
RFCS04025600CJTT1

Vishay Huntington
2,587

PEI Genesis
PKB05RFC24-12PY

Amphenol Corporation
1 : $0.0
10 : $0.0
25 : $0.0
50 : $0.0
100 : $0.0
0
PKB05RFC24-12PX

Amphenol Corporation
1 : $0.0
10 : $0.0
25 : $0.0
50 : $0.0
100 : $0.0
0

Richardson RFPD
P2RFC-2275-540

RF Industries CBL ASSY; 4.3/10 MALE TO 4.3/10 MALE; TFT-402LF; P
RoHS : Not Compliant
19 : $154.45
0
INTRFCEV

Microchip Technology Inc Power Supply And Interface Noise Board
RoHS : Compliant
19 : $95.3
0
P2RFC-2275-420

RF Industries CBL ASSY; 4.3/10 MALE TO 4.3/10 MALE; TFT-402LF; P
RoHS : Not Compliant
0

Chip 1 Exchange
D12-100-562R-FCS

Vishay Intertechnologies INSTOCK
340,000
D12-100-768R-FCS

Vishay Intertechnologies INSTOCK
170,000
D12931RFCS

INSTOCK
5,000
D25210RFCS

Vishay Roederstein INSTOCK
5,000
D25210RFCS

Vishay Roederstein INSTOCK
5,000
D25511RFCS-1

INSTOCK
5,000
D12681RFCS

Vishay Intertechnologies INSTOCK
5,000
D12681RFCS

Vishay Intertechnologies INSTOCK
5,000
A38499RFCS

INSTOCK
5,000
D25820RFCS

Vishay Roederstein INSTOCK
5,000
D12124RFCS

Vishay Draloric INSTOCK
4,950
D25215RFCS

Vishay Roederstein INSTOCK
2,715
D25150RFCS

INSTOCK
2,660
RFC16474F

Dubilier INSTOCK
1,500
RFC0807BV-823

Coilcraft Inc INSTOCK
360

Avnet Abacus
H836RFCA

TE Connectivity Res Metal Film 36 Ohm 1 14W 50ppmC Conformal AXL ThruHole Bandoliered (Alt: 1-1879625-4)
RoHS : Compliant
0
H8470RFCA

TE Connectivity Resistor 470 Ohm 1 250 mW Axial Leaded Metal Film Precision (Alt: 4-1879625-1)
RoHS : Compliant
0
05RFCLF010

TE Connectivity Multiconductor Cable 5Conductors 24AWG Tin Plated Copper Black (Alt: 05RFCLF010)
RoHS : Compliant
0
228ADVARFCAD

CTS Corporation (Alt: 228ADVARFCAD)
RoHS : Compliant
0
228ADS2ARFCWE

CTS Corporation (Alt: 228ADS2ARFCWE)
RoHS : Compliant
0
228AMVARFCWAR

CTS Corporation (Alt: 228AMVARFCWAR)
RoHS : Compliant
0
228CMVARFCWCR

CTS Corporation - Tape and Reel (Alt: 228CMVARFCWCR)
RoHS : Compliant
0
CAS17C271JARFC

KEMET Corporation Ceramic Suppression Capacitor 270 pF 5 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C271JARFC)
RoHS : Compliant
0
CAS17C681KARFC

KEMET Corporation Ceramic Suppression Capacitor 680 pF 10 X1 Y2 250 VAC 250 VAC 1808 4520 Metric (Alt: CAS17C681KARFC)
RoHS : Compliant
0
CAS26C102MARFC

KEMET Corporation Ceramic Suppression Capacitor 1000 pF 20 X1 Y2 250 VAC 250 VAC 2211 5728 Metric (Alt: CAS26C102MARFC)
RoHS : Compliant
0
CAS18C271KARFC

KEMET Corporation Ceramic Suppression Capacitor 270 pF 10 X1 Y2 250 VAC 250 VAC 1812 4532 Metric (Alt: CAS18C271KARFC)
RoHS : Compliant
0
CAS21C182JARFC

KEMET Corporation Ceramic Suppression Capacitor 1800 pF 5 X1 Y2 250 VAC 250 VAC 2220 5650 Metric (Alt: CAS21C182JARFC)
RoHS : Compliant
0
CAS26C151KARFC

KEMET Corporation Ceramic Suppression Capacitor 150 pF 10 X1 Y2 250 VAC 250 VAC 2211 5728 Metric (Alt: CAS26C151KARFC)
RoHS : Compliant
0
CAS26C391KARFC

KEMET Corporation Ceramic Suppression Capacitor 390 pF 10 X1 Y2 250 VAC 250 VAC 2211 5728 Metric (Alt: CAS26C391KARFC)
RoHS : Compliant
0
PMF 4118V SRF/C

Flex Ltd POL 33Vi 055 18Vo 10A 18W SMT TR Leadfree Reflow temp capable POLA (Alt: PMF 4118V SRF/C)
RoHS : Compliant
0

Avnet Asia
R5F10RFCAFP#50

Renesas Electronics Corporation MCU 16-Bit RL78 CISC 32KB Flash 1.6V to 5.5V 44-Pin LQFP Tray (Alt: R5F10RFCAFP#50)
RoHS : Compliant
0
TLP785(GR,F(C

Toshiba America Electronic Components (Alt: TLP785(GR,F(C)
RoHS : Compliant
0
CAS17C331KARFC

KEMET Corporation Ceramic Suppression Capacitor, 330 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] (Alt: CAS17C331KARFC)
RoHS : Compliant
50,000 : $0.50863
25,000 : $0.52167
10,000 : $0.53539
5,000 : $0.54986
3,000 : $0.5574
2,000 : $0.56514
1,000 : $0.5731
0
CAS17C102KARFC

KEMET Corporation Ceramic Suppression Capacitor, 1000 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 1808 [4520 Metric] (Alt: CAS17C102KARFC)
RoHS : Compliant
0
TC75W71FU,RF(CB

Toshiba America Electronic Components TOSTC75W71FU,RF(CB CMOS LINEAR IC (Alt: TC75W71FU,RF(CB)
RoHS : Compliant
0
CAS21C472KARFC

KEMET Corporation Ceramic Suppression Capacitor, 4700 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2220 [5650 Metric] (Alt: CAS21C472KARFC)
RoHS : Compliant
0
R5F10RFCAFP#10

Renesas Electronics Corporation Microcontroller 16-Bit RL78 CISC 32KB Flash 44-Pin LQFP (Alt: R5F10RFCAFP#10)
RoHS : Compliant
0
QTLP650C4TR/FC15-21SYGC/S530-E2/TR8

Everlight Electronics Co Ltd (Alt: QTLP650C4TR/FC15-21SYGC/S530-E2/TR8)
RoHS : Compliant
0
NCP456RFCCT2G

onsemi Load Switch, 2 A Single, For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
RFCM3328TR13

Qorvo (Alt: RFCM3328TR13)
RoHS : Compliant
0
CAS18C102KARFC

KEMET Corporation (Alt: CAS18C102KARFC)
RoHS : Compliant
0
CAS26C222KARFC

KEMET Corporation Ceramic Suppression Capacitor, 2200 pF, ? 10%, X1 / Y2, 250 VAC, 250 VAC, 2211 [5728 Metric] (Alt: CAS26C222KARFC)
RoHS : Compliant
0
CAS17C102MARFC

KEMET Corporation (Alt: CAS17C102MARFC)
RoHS : Compliant
0
RFCM3327TR13

Qorvo (Alt: RFCM3327TR13)
RoHS : Compliant
0

Avnet Silica
1320XRFC

NXP Semiconductors Daughter Card RF Zigbee Communication Networking MC9S08 (Alt: 1320XRFC)
RoHS : Compliant
0
SRFC015-100

Antenova M2M Zhengi flexible antenna 100mm cable Ipex Cellular 3G 4G and LTE (Alt: SRFC015-100)
RoHS : Compliant
0
SRFC025-100

Antenova M2M AVIA 3G FLEXIBLE ANTENNA 100mm cable (Alt: SRFC025-100)
RoHS : Compliant
0
SRFC025-200

Antenova M2M AVIA 3G FLEXIBLE ANTENNA 200mm cable (Alt: SRFC025-200)
RoHS : Compliant
0
RFCM3328TR13

Qorvo (Alt: RFCM3328TR13)
RoHS : Compliant
0
RFC02MM2STFTR

ROHM Semiconductor Super Fast Recovery Diode 200V 500mA 2Pin SOD123L TR (Alt: RFC02MM2STFTR)
RoHS : Compliant
0
NCP456RFCCT2G

onsemi Load Switch 2 A Single For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
M3030RFCPGP#33

Renesas Electronics Corporation 16BIT MCU M16C30P (Alt: M3030RFCPGP#33)
RoHS : Compliant
0
R5F10RFCAFP#50

Renesas Electronics Corporation (Alt: R5F10RFCAFP#50)
RoHS : Compliant
0
R5F10RFCGFP#50

Renesas Electronics Corporation (Alt: R5F10RFCGFP#50)
RoHS : Compliant
0
R5F10RFCAFP#10

Renesas Electronics Corporation (Alt: R5F10RFCAFP#10)
RoHS : Compliant
0
STM32WC-RFCKIT

STMicroelectronics Development Kit For STM32W RF Wireless Control (Alt: STM32WC-RFCKIT)
RoHS : Compliant
0

Component Electronics, Inc
D11010RFCS

Vishay Intertechnologies IN STOCK SHIP TODAY
1,000 : $0.08
100 : $0.09
1 : $0.12
3,000
RFC-8716-60

RF CONN IN STOCK SHIP TODAY
1,000 : $17.5
100 : $20.19
1 : $26.92
117
RFC-8714-60

RF CONN IN STOCK SHIP TODAY
1,000 : $12.5
100 : $14.42
1 : $19.23
46
RFC-8715-14

RF CONN IN STOCK SHIP TODAY
1,000 : $10.0
100 : $11.54
1 : $15.38
46
RFC1010B-104KE

Coilcraft Inc IN STOCK SHIP TODAY
RoHS : Compliant
1,000 : $1.0
100 : $1.15
1 : $1.54
10
SR-FC-HUB

IN STOCK SHIP TODAY
5
194R-FCA2

AB Connectors Ltd IN STOCK SHIP TODAY
1,000 : $25.0
100 : $28.85
1 : $38.46
3

EBV Elektronik
TLP785F(GR,F(C

Toshiba America Electronic Components Optocoupler 1CH Open Collector 5000Vrms 4Pin DIP Tube (Alt: TLP785F(GR,F(C)
RoHS : Compliant
10,600
TLP785(GR,F(C

Toshiba America Electronic Components Optocoupler DCIN 1CH Transistor DCOUT 4Pin DIP (Alt: TLP785(GR,F(C)
RoHS : Compliant
3,400
TLP785(D4-GR,F(C

Toshiba America Electronic Components Optocoupler DCIN 1CH DCOUT 4Pin PDIP SMD (Alt: TLP785(D4-GR,F(C)
RoHS : Compliant
1,600
NCP456RFCCT2G

onsemi Load Switch 2 A Single For Low Voltage Rail (Alt: NCP456RFCCT2G)
RoHS : Compliant
0
M3030RFCPGP#35

Renesas Electronics Corporation 16BIT MCU M16C30P (Alt: M3030RFCPGP#35)
RoHS : Compliant
0
CL8068404069606S RFCR

Intel Corporation Intel Core i59300H Processor 8M Cache up to 410 GHz FCBGA14F Tray (Alt: 999CXR)
RoHS : Compliant
0
CL8068404069418S RFCP

Intel Corporation Intel Core i79750H Processor 12M Cache up to 450 GHz FCBGA14F Tray (Alt: 999CXN)
RoHS : Compliant
0

FDH Electronics
PKB06RFC24-10T

Amphenol Aerospace Circular Conn
13
PKT07RFC20-22P

Amphenol Aerospace Circular Conn
5
PKB06RFC24-12T

Amphenol Aerospace Circular Conn
5
RFC1035-116 ISS A

W L Gore & Associates Cable Assembly
1 : $4,302.222
5 : $4,302.222
10 : $3,951.02
25 : $3,396.491
50 : $3,396.491
100 : $3,281.356
250 : $3,173.77
500 : $3,173.77
1,000 : $3,173.77
2,500 : $3,173.77
10,000 : $3,173.77
3
PERF CARD STK

FDH Electronics Wire Placehldr
2

Flip Electronics
R5F10RFCAFP#30

Renesas Electronics Corporation Stock
RoHS : Compliant
1,221

Master Electronics
SEALINTRFCL MDM-21SPERMIL-

ITT Interconnect Solutions
RoHS : Compliant
500 : $2.52
375 : $2.58
250 : $2.76
125 : $3.68
0
RFC-DUAL-FAN

Phoenix Contact Fan module for Remote Field Controllers RFC 430 ETH-IB / RFC 450 ETH-IB
RoHS : Compliant
5 : $662.36
1 : $697.22
0
H836RFCA

TE Connectivity H8 36R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H8470RFCA

TE Connectivity H8 470R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
RFC-4072S

Phoenix Contact PLCnext Control with 4 x 10/100/1000 Ethernet - PROFINET controller with integrated PROFIsafe safety controller - PROFINET device - IP20 degree of protection - pluggable parameterization memory
RoHS : Compliant
5 : $7,425.13
3 : $7,443.74
1 : $7,539.18
0
H820RFCA

TE Connectivity H8 20R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
H4P33RFCA

TE Connectivity H4P 33R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H882RFCA

TE Connectivity H8 82R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
SEAL-INTRFCL -MDM-21S-PER-

ITT Interconnect Solutions Conn Micro D Subminiature RCP 21 POS 1.27mm ST Panel Mount
RoHS : Compliant
500 : $2.5
375 : $2.55
250 : $3.22
125 : $5.23
0
H4P68RFCA

TE Connectivity H4P 68R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
CRF-CX-D

Mencom Corporation Zinc Plated Iron Female Coding Pin for MIXO
RoHS : Compliant
7,500 : $1.67
5,000 : $1.68
2,500 : $1.72
1,000 : $1.77
500 : $1.87
250 : $1.93
100 : $2.02
10 : $2.48
0
H4P150RFCA

TE Connectivity H4P 150R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H4P910RFCA

TE Connectivity H4P 910R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.4853
10,000 : $0.4917
7,500 : $0.5207
5,000 : $0.5349
2,500 : $0.5547
1,000 : $0.6044
500 : $0.6312
250 : $0.6328
0
H839RFCA

TE Connectivity H8 39R 1% 50PPM
Thin Film Leaded Precision resistors
Fixed Resistor
RoHS : Compliant
15,000 : $0.3694
10,000 : $0.3703
7,500 : $0.4018
5,000 : $0.4028
2,500 : $0.4295
1,000 : $0.4551
500 : $0.4765
250 : $0.4919
0
SRFC5STR48

Tripp Lite SRFC5STR48
RoHS : Compliant
100 : $100.29
50 : $101.63
20 : $104.41
10 : $108.89
5 : $113.76
1 : $122.94
0

TE Connectivity
6ESRFC3

TE Connectivity 6ESRFC3=F6987 Current Rating: 15 A Filter Connector Type: IEC 60320-1 C-13 Filter Connector Style: Female Receptacle Output Termination Type: 1/4" Faston Iec Unfiltered Inlets & Corcom Sr Series | 15 A IEC 60320-1 C-13 Female Receptacle 1/4" Faston | Part Number: 6ESRFC3 | Internal Number: 1609133-2 | TE Connectivity
RoHS : Compliant
500 : $5.74
250 : $5.94
100 : $6.14
50 : $6.33
25 : $6.53
10 : $6.73
1 : $6.93
1,544

Venkel Ltd.
RFCA0805A3T

VENKEL LTD RF Ceramic Antenna;0805;2.4GHz
RoHS : Not Compliant
0
RFCA1206AAT

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA0805A0T

VENKEL LTD RF Ceramic Antenna;0805;2.45GHz
RoHS : Not Compliant
0
RFCA1206K1T

VENKEL LTD RF Ceramic Antenna;1206;5GHz
RoHS : Not Compliant
0
RFCA0402A1T

VENKEL LTD RF Ceramic Antenna;0402;2.45GHz
RoHS : Not Compliant
0
RFCA1206E0T

VENKEL LTD RF Ceramic Antenna;1206;1.575GHz
RoHS : Not Compliant
0
RFCA3224YAT

VENKEL LTD RF Ceramic Antenna;3224;6.5GHz
RoHS : Not Compliant
0
RFCA1206Y1T

VENKEL LTD RF Ceramic Antenna;1206;7.37GHz
RoHS : Not Compliant
0
RFCA1206A5T

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA1206A1T

VENKEL LTD RF Ceramic Antenna;1206;2.4GHz
RoHS : Not Compliant
0
RFCA3708A0T

VENKEL LTD RF Ceramic Antenna;3708;2.4GHz
RoHS : Not Compliant
0

Vyrian
CAS21C472KARFC

KEMET Corporation Ceramic Capacitor, Multilayer, Ceramic, 10% +Tol, 10% -Tol, X7R, 15% TC, 0.0047uF, Surface Mount, 2220
17,124
RFC0807BV-474KE

Coilcraft Inc General Purpose Inductor, 470uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
16,430
RFC0807BV-105KE

Coilcraft Inc General Purpose Inductor, 1000uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
15,002
NCP392BRFCCT1G

onsemi Power Supply Support Circuit, Fixed, 1 Channel, PBGA12
RoHS : Compliant
13,189
IRFC7314B

Infineon Technologies AG
12,015
RFC0807BV-154KE

Coilcraft Inc General Purpose Inductor, 150uH, 10%, 1 Element, Ferrite-Core
RoHS : Compliant
9,964
NCP392ARFCCT1G

onsemi Power Supply Support Circuit, Adjustable, 1 Channel, PBGA12
RoHS : Compliant
9,755
IRFC7416B

Infineon Technologies AG
9,028
CAS17C102KARFC

KEMET Corporation Ceramic Capacitor, Multilayer, Ceramic, 10% +Tol, 10% -Tol, X7R, 15% TC, 0.001uF, Surface Mount, 1808
7,959
VT451RFCR-ADJ

Analog Devices Inc
5,261
NCP392DRFCCT1G

onsemi Power Supply Support Circuit, Adjustable, 1 Channel, PBGA12
RoHS : Compliant
4,091
XQVU095-1RFC1517I

AMD Xilinx Field Programmable Gate Array, 1176000-Cell, PBGA1517
RoHS : Not Compliant
3,989
XQVU065-2RFC1517E

AMD Xilinx Field Programmable Gate Array, 783300-Cell, PBGA1517
RoHS : Not Compliant
2,845
XQVU095-2RFC1517E

AMD Xilinx Field Programmable Gate Array, 1176000-Cell, PBGA1517
RoHS : Not Compliant
1,987
XQVU095-1RFC1517M

AMD Xilinx Field Programmable Gate Array, 1176000-Cell, PBGA1517
RoHS : Not Compliant
1,593

Link URL



Does ALLDATASHEET help your business so far?  [ DONATE ]  

About Alldatasheet   |   Advertisement   |   Contact us   |   Privacy Policy   |   Link to Datasheet    |   Link Exchange   |   Manufacturer List
All Rights Reserved짤Alldatasheet.com


Mirror Sites
English : Alldatasheet.com  |   English : Alldatasheet.net  |   Chinese : Alldatasheetcn.com  |   German : Alldatasheetde.com  |   Japanese : Alldatasheet.jp
Russian : Alldatasheetru.com  |   Korean : Alldatasheet.co.kr  |   Spanish : Alldatasheet.es  |   French : Alldatasheet.fr  |   Italian : Alldatasheetit.com
Portuguese : Alldatasheetpt.com  |   Polish : Alldatasheet.pl  |   Vietnamese : Alldatasheet.vn
Indian : Alldatasheet.in  |   Mexican : Alldatasheet.com.mx  |   British : Alldatasheet.co.uk  |   New Zealand : Alldatasheet.co.nz
Family Site : ic2ic.com  |   icmetro.com