Electronic Components Datasheet Search
  English  ▼

X  



FC152 Distributor

DistributorPart #ManufacturerDescriptionPriceQty.
BuyNow

Avnet Americas
ADFC15-2450.00-A-T-EVB

Abracon Corporation SMD 2.45GHZ DIELECTRIC BAND PASS FILTER - Bag (Alt: ADFC15-2450.00-A-T-EVB)
RoHS : Compliant
0
IMLTFC152H-L6L

Panduit Corp - Bulk (Alt: IMLTFC152H-L6L)
RoHS : Not Compliant
800 : $2.31193
400 : $2.3485
200 : $2.39218
100 : $2.652
50 : $2.6656
0
ADFC15-2450.00-A-T

Abracon Corporation - Tape and Reel (Alt: ADFC15-2450.00-A-T)
RoHS : Compliant
1,000,000 : $0.125
500,000 : $0.12821
250,000 : $0.13158
100,000 : $0.13514
10,000 : $0.14286
0
IMLTFC152S-C6L

Panduit Corp - Bulk (Alt: IMLTFC152S-C6L)
RoHS : Not Compliant
1,600 : $2.15337
800 : $2.18744
400 : $2.22812
200 : $2.27918
100 : $2.33007
0

Mouser Electronics
ADFC15-2450.00-A-T

Abracon Corporation Signal Conditioning 2.45 GHZ
RoHS : Compliant
1 : $0.36
10 : $0.29
25 : $0.251
100 : $0.236
250 : $0.218
500 : $0.205
1,000 : $0.193
5,000 : $0.168
10,000 : $0.157
9,537
IMLTFC152H-L6L

Panduit Corp Cable Ties Fully Coated IMLT Tie, 316L SS, Heavy, 521mm (20.5"), 0.25 mm (0.010") thk
RoHS : Compliant
1 : $3.64
10 : $3.37
50 : $3.09
100 : $2.98
250 : $2.92
500 : $2.85
1,000 : $2.79
2,500 : $2.74
0
0986 EFC 152

Lumberg Automation Circular Metric Connectors
RoHS : Compliant
1 : $22.38
10 : $18.17
20 : $17.99
50 : $17.34
100 : $16.65
200 : $16.06
500 : $15.8
0
0976 PFC 152

Lumberg Automation Circular Metric Connectors
RoHS : Compliant
1 : $23.01
10 : $19.0
25 : $18.49
50 : $18.09
100 : $17.68
250 : $17.28
0
0936 DFC 152/2M

Lumberg Automation Sensor Cables / Actuator Cables
1 : $37.08
10 : $30.3
50 : $29.7
100 : $28.91
250 : $28.05
0
IMLTFC152S-C6L

Panduit Corp Cable Ties Fully Coated IMLT Tie, 316L SS, Standard, 521mm (20.5"), 0.25 mm (0.010") thk
RoHS : Compliant
1 : $3.39
10 : $3.14
25 : $3.05
100 : $2.77
300 : $2.69
500 : $2.64
1,000 : $2.59
2,500 : $2.54
0
QTLP650C4TR/FC15-21SYGC/S530-E2/TR8

Everlight Electronics Co Ltd Single Color LEDs
6,000 : $0.054
10,000 : $0.049
0
QTLP650C2TR/FC15-21SURC/S530-A3/TR8

Everlight Electronics Co Ltd Everlight
6,000 : $0.081
10,000 : $0.073
24,000 : $0.07
0
QTLP650C74TR/FC15-22SDRSYGC/S530-A2/TR8

Everlight Electronics Co Ltd Everlight
6,000 : $0.214
10,000 : $0.198
24,000 : $0.191
0
QTLP650C3TR/FC15-21UYC/S530-A3/TR8

Everlight Electronics Co Ltd Single Color LEDs
6,000 : $0.101
10,000 : $0.094
24,000 : $0.084
0

Newark
VFC-152

Dwyer Instruments Inc Liquid Flowmeter, 40Lpm, 100Psi, 1" Fnpt; Flow Rate Min:4L/Min; Flow Rate Max:40L/Min; Supply Voltage Min:-; Supply Voltage Max:-; Product Range:Visi-Float Vfc Series; Accuracy:2%; Port Size:1"; Pressure Max:100Psi Rohs Compliant: Yes |Dwyer VFC-152
RoHS : Compliant
1 : $205.14999
0
VFC-152

Dwyer Instruments Inc Liquid Flowmeter, 40Lpm, 100Psi, 1" Fnpt; |Dwyer VFC-152
RoHS : Compliant
1 : $281.10001
0
VFC-152-EC

Dwyer Instruments Inc Liquid Flowmeter, 40Lpm, 100Psi, 1" Fnpt; |Dwyer VFC-152-EC
RoHS : Compliant
1 : $303.48999
0
VFC-152-EC

Dwyer Instruments Inc Liquid Flowmeter, 40Lpm, 100Psi, 1" Fnpt; Flow Rate Min:4L/Min; Flow Rate Max:40L/Min; Supply Voltage Min:-; Supply Voltage Max:-; Product Range:Visi-Float Vfc Series; Accuracy:2%; Port Size:1"; Pressure Max:100Psi Rohs Compliant: Yes |Dwyer VFC-152-EC
RoHS : Compliant
1 : $221.5
0
0976 PFC 152

Lumberg Automation 0976 Pfc 152; |Lumberg Automation 0976 PFC 152
RoHS : Not Compliant
10 : $19.36
0
ADFC15-2450.00-A-T

Abracon Corporation Dielectric Filter 2450Mhz 100Mhz Bandwid; |Abracon ADFC15-2450.00-A-T
RoHS : Compliant
10,000 : $0.183
30,000 : $0.179
50,000 : $0.176
0

RS
0976 PFC 152 (25005)

Lumberg Automation RECEPTACLE CONNECTOR, M12 FEMALE CONNECTOR, 5 POLES, PRINTED, CONTACTS, 25005
1 : $10.05
10
VFC-152

Dwyer Instruments Inc FLOWMETER;5" SCALE;END CONNECTION;1" F NPT;VFC-152 4-40 LPM WATER
1 : $247.3
0
RFC-1525

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-174/U CBL, 7FT., NON BOOTED
1 : $16.38
10 : $15.39
25 : $14.74
0
RFC-1526

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-174/U CBL, 10FT., NON BOOTED
1 : $19.19
10 : $18.04
25 : $17.28
0
RFC-1523

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-174/U CBL, 36", NON BOOTED
1 : $19.94
10 : $18.74
25 : $17.94
0
RFC-1521

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-174/U CBL, 12", NON BOOTED
1 : $10.72
10 : $10.08
25 : $9.65
0
RFC-1522

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-174/U CBL, 24", NON BOOTED
1 : $11.67
10 : $10.97
25 : $10.5
0
RFC-1524

Quest Technology International Inc CABLE ASSEMBLY, SMA PLUG X2, RG-174/U CBL, 5FT., NON BOOTED
1 : $14.5
10 : $13.63
25 : $13.05
0
DFC1520-01

Norgren CABLE,20M SEN 15P ANGL RTCH W/RATCHET CONN. ANGLED
1 : $2,203.63
0
VFC-152-EC

Dwyer Instruments Inc FLOWMETER;5" SCALE;END CONNECTION;1" F NPT;VFC-152-EC 4-40 LPM WATER
1 : $225.93
0
AFC15215-US

Panasonic Electronic Components CORDSET, FP0/M, ATM 1.5 METER CABLE
1 : $76.41
0
AFC15205-US

Panasonic Electronic Components CORDSET, FP0/M-ATM CABLE 50CM
1 : $67.64
0
AFC15205-US-S

Panasonic Electronic Components CORDSET, STRAIGHT, 0.5 METER, FP0/M TO ATM CABLE
1 : $92.76
5 : $88.13
10 : $85.34
0
IMLTFC152H-L6L

Panduit Corp STRONGHOLD FULLY COATED IMLT TIE, 316L SS, HEAVY, 20.5", 0.010" THICK
50 : $3.71
100 : $3.53
200 : $3.42
0
IMLTFC152S-C6L

Panduit Corp STRONGHOLD FULLY COATED IMLT TIE, 316L SS, STANDARD, 20.5", 0.010" THICK
100 : $2.8
200 : $2.66
400 : $2.55
0

Sager
IMLTFC152H-L6L

Panduit Corp Cable Ties Fully Coated IMLT Tie, 316L SS, Heavy, 5
50 : $2.81
150 : $2.54
250 : $2.34
550 : $2.25
1,100 : $2.25
2,750 : $2.23
0
IMLTFC152S-C6L

Panduit Corp Cable Ties Fully Coated IMLT Tie, 316L SS, Standard
100 : $2.36
300 : $2.18
600 : $2.1
1,200 : $2.1
2,900 : $2.07
0

TME
25005 0976 PFC 152

Lumberg Automation Connector: M12; socket; PIN: 5; female; THT; B code-Profibus
100 : $13.08
20 : $14.22
5 : $15.11
1 : $17.05
1

Richardson RFPD
PSMFC15-24

Wall Industries Inc ACTODC CONVERTR MOD
0
ADFC15-2450.00-A-T

Abracon Corporation RF Filter Band Pass 2450MHz 2400MHz to 2500MHz 1.7
RoHS : Compliant
1 : $0.134
2 : $0.1321
500,009 : $0.1212
0

Avnet Abacus
ADFC15-2450.00-A-T

Abracon Corporation - Tape and Reel (Alt: ADFC15-2450.00-A-T)
RoHS : Compliant
0

Avnet Asia
QTLP650C4TR/FC15-21SYGC/S530-E2/TR8

Everlight Electronics Co Ltd (Alt: QTLP650C4TR/FC15-21SYGC/S530-E2/TR8)
RoHS : Compliant
0

Braemac Americas-Symmetry
ADFC15-2450.00-A-T

Abracon Corporation
RoHS : Compliant
1 : $0.12
0

Master Electronics
ADFC15-2450.00-A-T

Abracon Corporation RF Filter Band Pass 2450MHz 2400MHz to 2500MHz 1.7dB 50Ohm SMD 4Pin 0402 T/R
RoHS : Compliant
100,000 : $0.1559
50,000 : $0.1563
30,000 : $0.1567
10,000 : $0.1571
7,500 : $0.1717
5,000 : $0.1725
2,500 : $0.2
4,900
AFC15205P-US

Panasonic Electronic Components FP0/M ATM cable 50cm w/ext pwr line
RoHS : Compliant
25 : $53.05
10 : $54.14
5 : $55.24
1 : $56.37
4
AFC15205-US

Panasonic Electronic Components Cordset; FP0/M--ATM cable 50cm
RoHS : Compliant
100 : $39.79
50 : $40.6
25 : $41.43
10 : $42.28
5 : $43.14
1 : $44.02
4
AFC15215P-US

Panasonic Electronic Components FP0/M ATM cable 1.5m w/ext pwr line
RoHS : Compliant
20 : $72.47
10 : $76.41
5 : $81.51
1 : $109.0
1

Vyrian
JSFC1520MB-2AN

Amphenol Corporation MIL Series Connector, Composite, Male, Receptacle
779

Link URL



Does ALLDATASHEET help your business so far?  [ DONATE ]  

About Alldatasheet   |   Advertisement   |   Contact us   |   Privacy Policy   |   Link to Datasheet    |   Link Exchange   |   Manufacturer List
All Rights Reserved짤Alldatasheet.com


Mirror Sites
English : Alldatasheet.com  |   English : Alldatasheet.net  |   Chinese : Alldatasheetcn.com  |   German : Alldatasheetde.com  |   Japanese : Alldatasheet.jp
Russian : Alldatasheetru.com  |   Korean : Alldatasheet.co.kr  |   Spanish : Alldatasheet.es  |   French : Alldatasheet.fr  |   Italian : Alldatasheetit.com
Portuguese : Alldatasheetpt.com  |   Polish : Alldatasheet.pl  |   Vietnamese : Alldatasheet.vn
Indian : Alldatasheet.in  |   Mexican : Alldatasheet.com.mx  |   British : Alldatasheet.co.uk  |   New Zealand : Alldatasheet.co.nz
Family Site : ic2ic.com  |   icmetro.com