| Electronic Components Datasheet Search |
|
FC142 Distributor |
| Distributor | Part # | Manufacturer | Description | Price | Qty. BuyNow | |
![]() Avnet Americas | SFC-142-T2-F-D-A | Samtec Inc | - Bulk (Alt: SFC-142-T2-F-D-A) RoHS : Compliant | 0 | ||
| TFC-142-02-F-D-K-TR | Samtec Inc | PCB Header, Board-to-Board, Wire-to-Board, 2.9 A, 2 Rows, 84 Contacts, Surface Mount, TFC Series - Tape and Reel (Alt: TFC-142-02-F-D-K-TR) RoHS : Compliant | 0 | |||
| SFC-142-T2-L-D-A | Samtec Inc | - Bulk (Alt: SFC-142-T2-L-D-A) RoHS : Compliant | 0 | |||
| SFC-142-T2-F-D-K-TR | Samtec Inc | - Tape and Reel (Alt: SFC-142-T2-F-D-K-TR) RoHS : Compliant | 0 | |||
| HSMF-C142 | Broadcom Limited | - Tape and Reel (Alt: HSMF-C142) RoHS : Compliant |
| 0 | ||
![]() Mouser Electronics | HSMF-C142 | Broadcom Limited | Multi-Color LEDs Chip Deep Red/Green BiColor RoHS : Compliant |
| 2,115 | |
| FC142DD | ABB Low Voltage Products and Systems | D-Sub Standard Connectors 10A,INSERT,FEMALE,DD42,CRIMP |
| 0 | ||
| FC1429-10-SS | Fascomp electronic hardware | Standoffs & Spacers 1/2 HEX X 1/2 |
| 0 | ||
| FC1423-25-SS | Fascomp electronic hardware | Standoffs & Spacers 1/2 HEX X 1/8 |
| 0 | ||
| UT06FC142G1SH | SOURIAU-SUNBANK | Standard Circular Connector CABLEPLUG |
| 0 | ||
| UTS1FC142G1P | SOURIAU-SUNBANK | Standard Circular Connector |
| 0 | ||
| 530FC142M800DG | Skyworks Solutions Inc | Standard Clock Oscillators Single Freq LJ osc XO,OE P1/2,10-1417MHz RoHS : Compliant |
| 0 | ||
| 530FC142M800DGR | Skyworks Solutions Inc | Standard Clock Oscillators Single Freq LJ osc XO,OE P1/2,10-1417MHz RoHS : Compliant |
| 0 | ||
![]() Newark | VFC-142-EC | Dwyer Instruments Inc | Flowmeter, Water, 1-10Gpm; Sensor Type:Flowmeter; Flow Rate Min:1Gpm (Us); Flow Rate Max:10Gpm (Us); Operating Pressure Min:-; Operating Pressure Max:100Psi; Supply Voltage Min:-; Supply Voltage Max:-; Accuracy:± 2%; Media Type:Waterrohs Compliant: Yes RoHS : Compliant |
| 1 | |
| VFC-142 | Dwyer Instruments Inc | Flowmeter, Water, 1-10Gpm; |Dwyer VFC-142 RoHS : Compliant |
| 0 | ||
| VFC-142 | Dwyer Instruments Inc | Flowmeter, Water, 1-10Gpm; Sensor Type:Flowmeter; Flow Rate Min:1Gpm (Us); Flow Rate Max:10Gpm (Us); Operating Pressure Min:-; Operating Pressure Max:100Psi; Supply Voltage Min:-; Supply Voltage Max:-; Accuracy:± 2%; Media Type:Waterrohs Compliant: Yes RoHS : Compliant |
| 0 | ||
| FC-142-D | Labfacility Limited | Compression Fitting, 1/8" Bspt, Ss; |Labfacility FC-142-D RoHS : Compliant |
| 0 | ||
| HSMF-C142 | Broadcom Limited | Led, Red/Green, 66/33Mcd, Smd; |Broadcom HSMF-C142 RoHS : Compliant |
| 0 | ||
| HSMF-C142 | Broadcom Limited | Led, Red/Green, 66/33Mcd, Smd; |Broadcom HSMF-C142 RoHS : Compliant |
| 0 | ||
| VFC-142-EC | Dwyer Instruments Inc | Flowmeter, Water, 1-10Gpm; |Dwyer VFC-142-EC RoHS : Compliant |
| 0 | ||
| UT06FC142G1SH | SOURIAU-SUNBANK | Ut06Fc142G1Sh; |Souriau-Sunbank/eaton UT06FC142G1SH RoHS : Not Compliant |
| 0 | ||
![]() RS | VFC-142-EC | Dwyer Instruments Inc | FLOWMETER;VFC;VFC-142-EC;ACRYLIC;2% FS ACC;1-10 GPM WATER;END CONNECTIONS |
| 1 | |
| FC142DD | Thomas & Betts | 10A INSERT FEMALE DD42 CRIMP RoHS : Compliant |
| 0 | ||
| VFC-142 | Dwyer Instruments Inc | FLOWMETER;VFC;VFC-142;ACRYLIC;2% FS ACC;1-10 GPM WATER |
| 0 | ||
| RFC-1423 | Quest Technology International Inc | CABLE ASSEMBLY, TNC PLUG X2, RG-59B/U CBL, 36" |
| 0 | ||
| RFC-1425 | Quest Technology International Inc | CABLE ASSEMBLY, TNC PLUG X2, RG-59B/U CBL, 7FT. |
| 0 | ||
| RFC-1424 | Quest Technology International Inc | CABLE ASSEMBLY, TNC PLUG X2, RG-59B/U CBL, 5FT. |
| 0 | ||
| RFC-1426 | Quest Technology International Inc | CABLE ASSEMBLY, TNC PLUG X2, RG-59B/U CBL, 10FT. |
| 0 | ||
| DFC1420-01 | Norgren | CABLE,20M DBA SEN 15P RTCHT W/RATCHET CONN. HI FLEX |
| 0 | ||
![]() Bisco Industries | VFC-142-EC | Dwyer Instruments Inc | 1 | |||
![]() Onlinecomponents.com | FC142DD | Thomas & Betts | Female Crimp Terminal Insert - For Use With Series DD - 42 Contacts With Ground. RoHS : Compliant |
| 0 | |
![]() Sager | FC142DD | ABB Group | D-Sub Standard Connectors |
| 0 | |
| TFC-142-01-L-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T2-F-D-A | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| TFC-142-01-FM-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T1-FM-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| TFC-142-01-F-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T1-F-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T2-FM-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| TFC-142-02-F-D-K-TR | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| TFC-142-01-LM-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T2-L-D-A | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T1-L-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T2-LM-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T2-L-D | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
| SFC-142-T2-F-D-K-TR | Samtec Inc | Headers & Wire Housings RoHS : Compliant | 0 | |||
![]() TME | HSMF-C142 | Broadcom Limited | LED; red/green; SMD; 1.6÷2.4VDC; 3x1x2mm; 120°; 20mA; 72mW; chipLED RoHS : Compliant |
| 0 | |
![]() Interstate Connecting Components | UTS1FC142G1P | SOURIAU-SUNBANK | 0 | |||
![]() PEI Genesis | UT06FC142G1SH | SOURIAU-SUNBANK | RoHS : Compliant |
| 0 | |
| UTS6FC142G1S | SOURIAU-SUNBANK |
| 0 | |||
![]() Richardson RFPD | 530FC142M800DG | Skyworks Solutions Inc | Oscillator XO 142.8MHz ±20ppm LVDS 55% 2.5V 6-Pin RoHS : Compliant |
| 0 | |
| 530FC142M800DGR | Skyworks Solutions Inc | Oscillator XO 142.8MHz ±20ppm LVDS 55% 2.5V 6-Pin RoHS : Compliant |
| 0 | ||
![]() EBV Elektronik | HSMF-C142 | Broadcom Limited | (Alt: HSMF-C142) RoHS : Compliant | 15,000 | ||
![]() Master Electronics | FC142DD | Thomas & Betts | Female Crimp Terminal Insert - For Use With Series DD - 42 Contacts With Ground. RoHS : Compliant |
| 0 | |
| TFC-142-01-L-D | Samtec Inc | Conn Shrouded Header HDR 84 POS 1.27mm Solder ST Thru-Hole RoHS : Compliant |
| 0 | ||
| SFC-142-T2-F-D-A | Samtec Inc | .050 Tiger Eye™ Cost-Effective Reliable Socket Strip RoHS : Compliant |
| 0 | ||
| TFC-142-01-FM-D | Samtec Inc | RoHS : Compliant |
| 0 | ||
| SFC-142-T1-FM-D | Samtec Inc | .050 Tiger Eye™ Cost-Effective Reliable Socket Strip RoHS : Compliant |
| 0 | ||
| SFC-142-T1-F-D-A | Samtec Inc | RoHS : Compliant |
| 0 | ||
| TFC-142-01-F-D | Samtec Inc | Conn Shrouded Header HDR 84 POS 1.27mm Solder ST Thru-Hole RoHS : Compliant |
| 0 | ||
| TFC-142-02-F-D-LC-TR | Samtec Inc | RoHS : Compliant |
| 0 | ||
| SFC-142-T1-F-D | Samtec Inc | .050 Tiger Eye™ Cost-Effective Reliable Socket Strip RoHS : Compliant |
| 0 | ||
| TFC-142-02-F-D | Samtec Inc | RoHS : Compliant |
| 0 | ||
| SFC-142-T2-FM-D | Samtec Inc | .050 Tiger Eye™ Cost-Effective Reliable Socket Strip RoHS : Compliant |
| 0 | ||
| TFC-142-02-L-D | Samtec Inc | RoHS : Compliant |
| 0 | ||
| TFC-142-02-F-D-K-TR | Samtec Inc | Conn Shrouded Header HDR 84 POS 1.27mm Solder ST SMD T/R RoHS : Compliant |
| 0 | ||
| TFC-142-01-LM-D | Samtec Inc | Conn Shrouded Header HDR 84 POS 1.27mm Solder ST Thru-Hole RoHS : Compliant |
| 0 | ||
| SFC-142-T2-L-D-A | Samtec Inc | .050 Tiger Eye™ Cost-Effective Reliable Socket Strip RoHS : Compliant |
| 0 | ||
![]() Neutron USA | VFC-142 | Dwyer Instruments Inc | Flowmeter;VFC;VFC-142;Acrylic;2% FS Acc;1-10 GPM water |
| 10 |
| Does ALLDATASHEET help your business so far? [ DONATE ] |
About Alldatasheet | Advertisement | Contact us | Privacy Policy | Link to Datasheet | Link Exchange | Manufacturer List All Rights Reserved짤Alldatasheet.com |
| Russian : Alldatasheetru.com | Korean : Alldatasheet.co.kr | Spanish : Alldatasheet.es | French : Alldatasheet.fr | Italian : Alldatasheetit.com Portuguese : Alldatasheetpt.com | Polish : Alldatasheet.pl | Vietnamese : Alldatasheet.vn Indian : Alldatasheet.in | Mexican : Alldatasheet.com.mx | British : Alldatasheet.co.uk | New Zealand : Alldatasheet.co.nz |
|
Family Site : ic2ic.com |
icmetro.com |